Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
connexion entre ip router et bus knx
#26
Citation :wagos 243-211.. car vachement fragiles selon moi.

Dodgy euh fragile comment ? J'en ai déjà manipulé pas mal , je n'ai jamais eu de problème.

Je voie 2 possibilité :
-Le fil qui se casse dans la borne, faut apprendre a bien dénuder les fils(utiliser un bon outil Idea ) et pas laisser de marque sur le fil
-L'insertion de fil sans que le connecteur soit pluggé, si on enfile le fil de travers on peut pousser le petit capuchon blanc qui va sortir.
Il faut tout simplement inséré les fils dans l'axe du trou...


Citation :Comme dit par Filou59, mon ip router gira était d'occasion et je n'ai pas envie de perdre encore 2semaines de test.. construction de maison prévue pour 2021..
je vous informe dès matériel reçu et dès que j'ai refait un test avec l'alim.. si ça ne fonctionne toujours pas
Si jamais tu n'y arrives toujours pas avec ton alim 24 et routeur MDT, si tu veux que je te la test pour faire un état des lieux fait moi signe.
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#27
Hello Filou59, je viens de recevoir l'alim 24V et en effet, cela a fonctionné directement... :-)
j'ai appris une chose... bien lire le mode d'emploi avant de se lancer, car c'était bien expliquer en page 2 du manuel du routeur gira.. par contre, je me retrouve avec un ip routeur "de trop" ,je vais voir si voltus reprends l'ip router mdt maintenant ^^

fin quoi que je pense à qqch.. la maison de 2 etages que je vais construire bientôt sera une maison unifamiliale dans un 1er temps mais on pense déjà à la scinder en 2 appartements lorsque les enfants auront quitté les lieux ^^
est-ce que je garde l'ip routeur pour scinder les 2 "circuits" et je les relie via les routeurs?

un tout grand merci  pour le support!!
Répondre
#28
Messages précédents (Le plus récent en haut)

Citation :Hello Filou59, je viens de recevoir l'alim 24V et en effet, cela a fonctionné directement.
Impec, tant mieux.


Citation :j'ai appris une chose... bien lire le mode d'emploi avant de se lancer, car c'était bien expliquer en page 2 du manuel du routeur gira
Oui, surtout qu'en KNX sauf a de rare exception les notices/mode d'emploi sont assez bien foutu. 

Après les expérimentations, montage a la volée peuvent parfois marcher, mais en cas d'echec toujours partir sur les preconisations fabriquant ou de la norme.


Citation :est-ce que je garde l'ip routeur pour scinder les 2 "circuits" et je les relie via les routeurs?

Oui bien sur, 2 routeur = 2 installations , pour le moment un cable réseau permetra de les relier ensemble.
Ensuite pour les séparer il te suffira de retirer la liaison réseau.
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#29
(23/10/2020, 11:39:38)drotiba a écrit : Hello Filou59, je viens de recevoir l'alim 24V et en effet, cela a fonctionné directement... :-)

Nickel !
Pour éviter tout malentendu : c'est bien le routeur Gira qui a marché ? (pas le nouveau)
Répondre
#30
Oui j'avais bien compris ^^
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#31
Petite précision, dans le cas présent, c'est vraiment pas conseillé de mettre le bus KNX sur l'alimentation...
L'avantage de certaines alimentations KNX par rapport à d'autres, c'est qu'il y a une alimentation secondaire que l'on peut utiliser pour alimenter quoi ? Ben, ce foutu router qui demande une alim secondaire Smile
Il est possible d'utiliser un POE mais alors, il faut déjà un switch POE sur place... Sinon, achat inutile

Remarque importante : une alimentation de 640mA a un total de 640mA pour ses 2 alimentations (KNX & secondaire ! ). Donc, si votre secondaire pompe 300mA, il ne restera que 340mA pour le bus KNX.

Par rapport au problème de connexion, je ne connais pas vos modems en France. mais en Belgique, pas besoin de configuration pour accéder au routeur IP/KNX...Il me semble que les règles informatiques sont un peu les mêmes partout dans le monde et surtout pour le résidentiel Wink
Il faut voir dans le détail tes paramètres du routeur dans ETS & potentiellement voir si le modem bride quelque chose mais j'en doute...


(23/10/2020, 13:51:07)filou59 a écrit : Oui j'avais bien compris ^^

Pour marquer @Filou, je te cite Wink
Je pense que tu m'avais demandé dans un poste précédent quel module pouvait utiliser une adresse physique supplémentaire, c'est le cas avec le routeur IP/KNX. Il a son registre d'horloge qui se fixe sur une seconde adresse pghysique.

Dibou,
Tu as dû remarquer qu'il y avait une seconde application pour le routeur : Registre d'horloge.
Tu dois appuyer + de 4 sec pour activer le mode programmation de cette partie du module

Bon amusement
Répondre
#32
Citation :L'avantage de certaines alimentations KNX par rapport à d'autres, c'est qu'il y a une alimentation secondaire que l'on peut utiliser pour alimenter quoi ? Ben, ce foutu router qui demande une alim secondaire

Hum, je suis pas trop d'accord avec ca, après tu nous diras peu être les préconisation de Gira la dessus, tu es le mieux placé pour nous les donner. Tongue


Mais de ce que j'ai pu voir a plusieurs reprise chez plusieurs fabriquant c'est qu'il est déconseillé d'utiliser la sortie auxilaire des alim pour alimenter les interface/routeur KNX qui ont besoin d'une alim.
Pourquoi ?
A cause de l'isolation galvanique qui est perdu, en cas de problème coté réseau, celui-ci peu remonter sur l'alim KNX

Là on parle bien d'un conseil de mise en oeuvre pour se prémunir de tout problème due a des surtensions ou autre, sinon la solution fonctionne, maintenant elle n'est pas conseillé.
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#33
(13/11/2020, 23:50:23)gkalpers@gmail.com a écrit : Tu as dû remarquer qu'il y avait une seconde application pour le routeur : Registre d'horloge.

Oh oui, j'ai remarqué ça.
Chez moi, la partie fonctions additionnelle (horloge/NTP/enregistreur) porte l'adresse physique 1.1.13 et celle-ci j'arrive très bien à la programmer.
Quant à la fonction routeur, son adresse physique est 1.1.0 (comme il se doit, puisque c'est un routeur…).

(13/11/2020, 23:50:23)gkalpers@gmail.com a écrit : Tu dois appuyer + de 4 sec pour activer le mode programmation de cette partie du module

Je ne parle pas de programmer l'adresse de groupe mais uniquement le programme (et les paramètres) du routeur.
Lorsque je lance un « Télécharger l'application » depuis ETS5, au bout d'un moment j'ai un retour « L’appareil ne répond pas dans un délai adapté. Connexion: Gira KNX/IP-Router (192.168.1.10:3671) »

192.168.1.10 c’est bien l’adresse IP de ce routeur dont j'utilise également la fonction passerelle/tunnelling pour programmer mes équipements depuis ETS. Alors je m'étais dit que peut être qu'une passerelle KNXnet/IP ne pouvait se programmer elle-même. Du coup, j'ai ressorti ma vieille interface USB/KNX, mais c'est pareil, le routeur ne répond pas aux demandes de programmation à son adresse physique 1.1.0.

Il me reste une piste, qui tient pour moi dans cette phrase en haut de la page 10 du mode d'emploi « If the device was programmed without an additional KNX/EIB data interface, the tunneling connection must be set up again after the programming process. ». Je ne comprends pas très bien ce que ça veut dire.

Mais bon, en même temps que j'écrivais ce message, je réalise que mon (vieux) routeur est en version I01 et qu'il y a eu des mises à jour de firmware depuis... Je vais explorer tout ça.
Répondre
#34
Citation :Je ne parle pas de programmer l'adresse de groupe mais uniquement le programme (et les paramètres) du routeur.
Lorsque je lance un « Télécharger l'application » depuis ETS5, au bout d'un moment j'ai un retour « L’appareil ne répond pas dans un délai adapté. Connexion: Gira KNX/IP-Router (192.168.1.10:3671) »

Je suis pas sur qu'il y ait une application a charger dans un routeur ou dans une interface, enfin après cela dépend peu être du produit et de la façon dont le fabriquant a implémenté ca.
Ensuite je fais tellement ca de maniere instinctive que je ne fais plus attention a certains détails, mais fait l'essai suivant :
Modifie les paramètre de ton routeur dans ETS.
Ensuite regarde les flag de celui-ci avant de faire quoi que ce soit.
Fait uniquement télécharger l'adresse pour voir, et regarde le statuts ou tu vois la barre de progression. Tu vas peu être voir défiler qq message qui sont parlant.
Il me semble que tous les paramètre sont envoyé sur cette étape et qu'il n'y a pas d'application a envoyer.
Ensuite regarde les flag si ils sont tous vert, alors tu n'as plus rien a faire.
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#35
(14/11/2020, 08:38:11)filou59 a écrit :
Citation :L'avantage de certaines alimentations KNX par rapport à d'autres, c'est qu'il y a une alimentation secondaire que l'on peut utiliser pour alimenter quoi ? Ben, ce foutu router qui demande une alim secondaire

Hum, je suis pas trop d'accord avec ca, après tu nous diras peu être les préconisation de Gira la dessus, tu es le mieux placé pour nous les donner. Tongue
Pour être honnête je n'utilise jamais l'alimentation secondaire... mais je parlais de cela pour ajouter une pierre à l'édifice Wink
Quand j'utilise un routeur IP, soit en POE si présent soit une alimentation propre...
parti pris simplement... et je suis d'accord sur le fait qu'un routeur IP devrait travailler uniquement via le bus sans alim secondaire...
Répondre
#36
Dibou,

Je ne comprends pas ton problème exactement...

Quand l'appareil annonce que le délai est dépassé, cela peut venir de 2 produits avec la même adresse physique sur le bus. mais ici, ça serait étrange...

Tu peux tout à fait programmer ton interface au travers d'elle-même.

Le routeur n'a besoin normalement d'aucun paramétrage pour pouvoir accéder au routeur. (sauf si tu as augmenté la sécurité du routeur et que tu brides tous les accès à ton réseau...)

ex en copie.
le Routeur est en DHCP.
Il est en mode full passant (c'est mon pupitre de test)


Pièces jointes Miniature(s)
       
Répondre
#37
(14/11/2020, 10:26:35)Dibou a écrit : Mais bon, en même temps que j'écrivais ce message, je réalise que mon (vieux) routeur est en version I01 et qu'il y a eu des mises à jour de firmware depuis... Je vais explorer tout ça.

Bon et bien tout cela n'augure rien de bon.
  • Si j'essaie de reprogrammer l'adresse de groupe (de la fonction routeur), j'obtiens dans ETS5 un message d'erreur bizarre que je n'avais jamais vu : « L’adresse du participant a été programmée avec succès, mais le contrôle final de cette procédure a échoué. Veuillez vérifier la topologie. Vous pourriez avoir besoin d’arrêter le mode de programmation (LED) manuellement. Connexion: Gira KNX/IP-Router (192.168.1.10:3671) » et même chose si je programme avec mon interface USB :  « L’adresse du participant a été programmée avec succès, mais le contrôle final de cette procédure a échoué. Veuillez vérifier la topologie. Vous pourriez avoir besoin d’arrêter le mode de programmation (LED) manuellement. Connexion: KNX-USB Data interface ».
    Et, effectivement, je dois rappuyer sur le bouton de programmation du routeur pour de sortir du mode programmation…
    Quant à vérifier la topologie, je veux bien mais je ne vois pas ce que je pourrais bien faire d'autre que de le mettre d'un côté sur mon réseau IP et de l'autre sur mon unique ligne KNX 1.1.x
  • Dans certaines versions de la doc (notamment celle-ci, qui est censée correspondre aux versions 1.0 à 3.0 du logiciel), il y a une procédure de factory reset (page 10). C’est bien sauf qu’elle ne fonctionne pas sur mon appareil. Je vais mettre ça sur le compte du fait que c’est un vieux modèle, étiqueté I01. Et, le fait est que cette procédure de remise à zéro ne figure pas dans la vieille doc que j'avais depuis toujours, datée de 2011, qui correspond aux toutes premières versions.
  • Enfin, j'ai téléchargé le package de mise à niveau du firmware trouvé ici, qui est censée permettre aux versions antérieures à la I02 (donc le mienne : I01) de passer à la version 2.0 de l'application. Le programme détecte bien mon routeur (dont le firmware est 1.0.322.13786) mais la procédure plante dès que je la lance avec un message d'erreur « Firmware could not be installed for device with IP 192.168.1.10 and serial number GIKXIPRT01270835.  This tool tries to reset the device. If not possible due a lost network connection try to reset the device manually. Please search again for new devices after device has booted sucessfully. See log for detailled information. » Le log ne dit rien de vraiment exploitable (messages d'erreurs).
En résumé, ce routeur a l'air malade, et je ne vois aucune solution pour le remettre sur pied. La vieille version de la documentation que j'évoquais ne comporte aucune procédure de remise en état d'usine... Bon...
En attendant, il assure sa fonction et, en réalité, je n'ai pas de besoin particulier de le reprogrammer pour l'instant. Mais c'est quand même perturbant d'avoir un appareil qui fonctionne à moitié... J'ai notamment le projet de créer une deuxième ligne et là je pourrais avoir besoin de changer son adresse.
Répondre
#38
Dibou c'est un peu normal car l'upgrade fait un reset de la passerelle Gira donc tu n'y a plus accès à partir de ton réseau et tu ne peux pas aller au bout de l'upgrade... tu dois faire l'upgrade firmware à partir d'une autre passerelle.
Le perfectionnement de soi et l'accession à sa légende personnelle passe obligatoirement par le partage de son savoir et de son expérience avec les profanes en demande d'initiation. (R. Bach)
Répondre
#39
(14/11/2020, 13:51:18)pollux06 a écrit : Dibou c'est un peu normal car l'upgrade fait un reset de la passerelle Gira donc tu n'y a plus accès à partir de ton réseau et tu ne peux pas aller au bout de l'upgrade... tu dois faire l'upgrade firmware à partir d'une autre passerelle.

Merci de ton aide, mais non je ne crois pas : je comprends que l'outil de mise à niveau fait un upgrade du firmware en pur TCP/IP sans passer par le KNX, depuis un PC. Du coup l'utilisation d'une autre passerelle ne changera pas grand chose

J'ai essayé de démarrer le routeur sans le relier du tout au bus KNX et dans ce cas, il est toujours bien détecté par l'outil de mise à niveau. Par contre, quand je lance la mise à jour, ça fait la même erreur « Firmware could not be installed for device with IP 192.168.1.10 and serial number GIKXIPRT01270835.  This tool tries to reset the device. If not possible due a lost network connection try to reset the device manually. Please search again for new devices after device has booted sucessfully. See log for detailled information. »

Après, ce message semble dire que l'outil a essayé de réinitialiser l'appareil mais qu'il n'a pas réussi. Puis il précise que si cela était impossible du fait d'une perte de connexion réseau, il faudrait que j'essaye de le réinitialiser à la main. Or, justement (c'était ma 2ᵉ puce), je n'arrive pas à le réinitialiser à la main non plus.

Pour mémoire, voilà ce que dit la documentation :
Citation :Alternatively, a factory reset can be carried out directly on the device via a sequence during start-up if, for example, no Ethernet connection is possible.
  • Make sure that the device is switched off.
  • Press and hold the programming button (1) and switch on the device.
  • Press and hold the programming button until the programming LED (4), the operation indication
  • LED (5) and the KNX LED (6) slowly flash simultaneously. This happens after approx. 30
  • seconds.
  • Briefly release the programming button (1), then press and hold it again until the programming
  • LED (4), the operation indication LED (5) and the KNX LED (6) flash quickly simultaneously.
  • The factory reset has been carried out.
  • Release the programming button.
  • The device need not be restarted following a factory reset.

Je mets donc le routeur sous tension en maintenant le bouton de programmation enfoncé aussi longtemps que j'en ai la patience (les 30 secondes sont largement dépassées)... sauf qu'il ne se passe rien de particulier : le routeur démarre normalement et à aucun moment les 3 LED clignotent simultanément.

En résumé : Si une chose est certaine à ce stade, c'est bien que mon routeur refuse de se réinitialiser.
Répondre
#40
pas d'idée... mais un routeur I01 c'est vraiment pas récent.... Wink

Idée qui me passe. Logiquement, via le Gira Project Assistant, tu peux mettre à jour le routeur IP KNX. Mais vu le numéro de série de ton produit j'en doute car il n'est pas dans le range habituel...

De plus dans un de tes liens, il y a ceci :
"Veuillez tenir compte de ce que les routeurs IP de la première génération (jusqu'à l'indice 01) sans mise à jour du logiciel ne sont pas compatibles avec la base de données de la version 2! Le routeur arrête alors son programme d'application! Dans ce cas, l'appareil peut être rétabli par le chargement de l'application correcte (version 1) via paire torsadée."

Donc, ce qu'à expliquer Pollux
Répondre
#41
(15/11/2020, 01:23:51)gkalpers@gmail.com a écrit : pas d'idée... mais un routeur I01 c'est vraiment pas récent.... Wink

Ben, oui, on fait ce qu'on peut…
Je l'ai acheté en le 4/09/2012 chez EIBMarkt pour la modique somme de 302,89 €.

(15/11/2020, 01:23:51)gkalpers@gmail.com a écrit : Idée qui me passe. Logiquement, via le Gira Project Assistant, tu peux mettre à jour le routeur IP KNX. Mais vu le numéro de série de ton produit j'en doute car il n'est pas dans le range habituel...

J'ai essayé aussi. Le routeur est bien détecté par GPA, mais la mise à niveau du firmware ne veut pas se faire non plus (même type de message d'erreur qu'avec l'outil de mise à niveau).
Mais c'est cohérent avec les informations trouvées ça et là qui sous-entendent clairement que la mise à niveau avec GPA n'est possible que pour les version ≥ I02.

Ce qui reste flou à mes yeux, c'est de savoir si, une fois flashé avec le firmware 2.0.134.47763, un vieux routeur (version < I02) devient équivalent à un routeur I02 (ou plus) et peut donc à nouveau être flashé avec le GPA jusqu'à se retrouver au goût du jour...

Je pense que je ne le saurai jamais.


(15/11/2020, 01:23:51)gkalpers@gmail.com a écrit : De plus dans un de tes liens, il y a ceci : "Veuillez tenir compte de ce que les routeurs IP de la première génération (jusqu'à l'indice 01) sans mise à jour du logiciel ne sont pas compatibles avec la base de données de la version 2! Le routeur arrête alors son programme d'application! Dans ce cas, l'appareil peut être rétabli par le chargement de l'application correcte (version 1) via paire torsadée." Donc, ce qu'à expliquer Pollux

Oui, j'ai bien vu ça. Il faut distinguer le firmware du routeur d'une part, et son application ETS (« base de données »), d'autre part. Là, ce qui est dit (me semble-t-il), c'est que la base de données ETS v 2.0 ne marchera pas avec un routeur dont le firmware n'a pas été mis à jour, ce qui me semble tout à fait admissible.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)