Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Défaillance module 0-10 V ?
#1
Bonjour

Je viens de recevoir un module Merten 647091 acheté d'occasion. C'est un variateur à sortie 0-10 V.
Voir ici pour l'application visée, mais c'est sans importance. Ce qu'il faut retenir, c'est que ça ne marche pas.

Je crois avoir diagnostiqué une défaillance du module Merten comme origine du problème. Mais comme je n'ai jamais utilisé de module avec sortie 0-10 V, je préfère avoir votre avis.

Ma question : si on branche un voltmètre à la sortie 0-10 V, n'est-on pas sensé mesurer une tension continue comprise entre 0 et 10[b] V et [/b](à la correction de courbe de variation près) proportionnelle à l'ordre de variation choisi, avec 0[b] % = 0 V, 100 % = 10 V ?[/b]

Sur le mien, la tension reste désespérément égale à zéro, bien que l'objet de confirmation d'état « Valeur » confirme bien des modifications de la valeur de variation. Avant de le renvoyer, je préfèrerais être sûr de mon diagnostic.

Merci bien.
Répondre
#2
J'ai retrouvé une vieille discussion qui parle des interfaces 0-10 V : http://www.knx-fr.com/showthread.php?tid=155
J'ai peut-être mal compris le fonctionnement des sorties 0-10 V (et 1-10 V, puisque ce n'est pas la même chose)

Il se pourrait que la sortie 0-10 V de mon actionneur ne soit pas une sorte d'alimentation qui produit une tension comprise entre 0 et 10 V mais plutôt une résistance variable asservie de façon que la tension en sortie soit celle visée. Dit autrement : il faudrait fournir le 10 V.
Cela serait assez cohérent avec la représentation qui figure dans la doc du module (voir p/j) où on voit plus une résistance variable qu'une alim.


Pièces jointes Miniature(s)
   
Répondre
#3
Oui il faut faire attention, je vais pas aller loin dans l'explication car je n'ai pas approfondi le sujet, mais il me semble qu'il y a une logique "Francaise" et les autres. Ou alors ca dépend du type de technologie.

Moi ca me paraissait logique que ce soit l'actionneur qui fournisse le 0-10V, mais bon je suis issue du monde industriel et je connais pas mal d’organe (Vanne de regul etc...) qui fonctionne comme ca.

Or je me souviens avoir eu une discussion avec un formateur KNX qui m'expliqué qu'en variation de lumière en france on avait peu être cette logique, mais qu’ailleurs se sont les driver des luminaires qui sont les générateurs il me semble.

Donc oui ton actionneur n'est peu être pas HS. Il faudrait chercher un peu sur le net pour approfondir et pour comprendre le système.
KNX Partner Base / Avancé
Répondre
#4
(20/05/2020, 08:18:40)filou59 a écrit : Oui il faut faire attention, je vais pas aller loin dans l'explication car je n'ai pas approfondi le sujet, mais il me semble qu'il y a une logique "Francaise" et les autres. Ou alors ca dépend du type de technologie.

Moi ca me paraissait logique que ce soit l'actionneur qui fournisse le 0-10V, mais bon je suis issue du monde industriel et je connais pas mal d’organe (Vanne de regul etc...) qui fonctionne comme ca.

Or je me souviens avoir eu une discussion avec un formateur KNX qui m'expliqué qu'en variation de lumière en france on avait peu être cette logique, mais qu’ailleurs se sont les driver des luminaires qui sont les générateurs il me semble.

Donc oui ton actionneur n'est peu être pas HS. Il faudrait chercher un peu sur le net pour approfondir et pour comprendre le système.

Merci de ton aide.

Quand à moi, je confirme que j'avais tout faux !

Après avoir lu attentivement le vieux post que j'avais trouvé, je viens de faire une expérience tout simple (voir schéma) consistant à prendre une alimentation 12 V CC à la relier aux bornes 0-10 V de mon module Merten, via une résistance¹ trouvée au fond d'un tiroir (1 kΩ), et à mesurer la tension aux bornes du modules (U sur le schéma).
   

Et tout se confirme : lorsque la consigne est de 100 %, U vaut 10,19 V. Lorsqu'on passe à 50 %, la tension baisse à 5,23 V et à 10 %, elle passe à 1,16 V. Intéressant de voir que la variation de tension prend un certain temps, ce qui démontre qu'il y a une petite boucle de régulation par rétroaction qui doit effectivement moduler la résistance pour atteindre la tension visée.
Intéressant de noter également que lorsque le module est commandé à 0 % sur l'entrée relative ou OFF sur l'entrée de commande tout ou rien, le relais s'ouvre mais la sortie 0-10 V passe à 10,18 V (correspondant à 100 %).

Moralité, le module n'est pas une sortie 0-10 V (au sens qu'il produirait une tension comprise entre 0 et 10 V, quelle que soit la charge). Il faudrait plutôt dire que c'est une sortie « à la norme 0-10 V » si tant est qu’une telle norme existe vraiment (genre ISO, EN, NF, DIN etc.).

Ce que je comprends maintenant, c'est qu'il y a deux types de contrôle en 0-10 V, un avec fourniture de la tension, l'autre sans. Cet article Wikipédia en anglais l'exprime clairement (current sinking / current sourcing).

C'est fou de penser que ce sujet puisse être aussi peu explicite dans la description des produits².

Du coup @Filou59, je propose de faire une publication un peu générale sur ce sujet important que tu pourras épingler.




¹ À l'attention de ceux qui ne comprendraient pas bien pourquoi la résistance : c'est juste pour éviter de se retrouver avec, d'un côté, une alimentation cherchant à tenir absolument ses 12 V (puisque c'est sa vocation, quelle que soit sa charge... jusqu'à ce qu'elle n'y arrive plus) et, de l'autre, une charge qui chercherait, elle, à faire baisser la tension à ses bornes en baissant sa propre résistance (c'est aussi sa vocation...). Cela se traduirait par une augmentation de l'intensité

² Je suis tombé par hasard sur un contre-exemple avec la documentation de ce produit Lunatone (un convertisseur 0-10 V vers DALI). Il font bien la différence entre « passive and active 0-10V input ». On voit bien sur les schémas en bas de la page 3 les deux situations.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)