Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Problème de programmation : "Plus d'un participant est en mode programmation"
#26
Bonjour
as tu arrêté le pc ?
Pas restart avant de réessayer de te connecter au bus.
J'ai déjà eu le cas et il faut vraiment éteindre le pc

L alim n'a peut-être pas de paramètres....
Répondre
#27
(04/08/2021, 17:52:35)fabric24 a écrit : Bonjour
as tu arrêté le pc ?
Pas restart avant de réessayer de te connecter au bus.
J'ai déjà eu le cas et il faut vraiment éteindre le pc

L alim n'a peut-être pas de paramètres....

Bonjour, je n'avais en effet pas pensé à arrêter completement le PC. Je viens d'essayer et malheureusement ca ne change rien ...

Ca me rend fou cette histoire
Répondre
#28
Pour moi c'est ta paserrelle qui est pas configuré correctement : 15.15.0

Au niveau de ta passerelle IP, comment est-elle configuré ?

-Il faut lui attribué une adresse Physique.
-Il faut lui mettre une adresse Individuelle pour ETS (15.15.0 : C'est pas top, il vaut mieux utiliser une adresse sur ta ligne 1.1.241 par exemple)
-Suivant ta passerelle il faudra lui attribuer des adresse virtuelle qui servent pour les connexions style superviseur.

Bref, regarde le manuel de ton produit si c'est pas déjà fait et suit scrupuleusement toutes les étapes.
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#29
(05/08/2021, 16:52:06)filou59 a écrit : Pour moi c'est ta paserrelle qui est pas configuré correctement : 15.15.0

Au niveau de ta passerelle IP, comment est-elle configuré ?

-Il faut lui attribué une adresse Physique.
-Il faut lui mettre une adresse Individuelle pour ETS (15.15.0 : C'est pas top, il vaut mieux utiliser une adresse sur ta ligne 1.1.241 par exemple)
-Suivant ta passerelle il faudra lui attribuer des adresse virtuelle qui servent pour les connexions style superviseur.

Bref, regarde le manuel de ton produit si c'est pas déjà fait et suit scrupuleusement toutes les étapes.

Merci mais impossible de lui remettre une adresse, j'obtiens le fameux message d'erreur.
Je vais rapporter ma passerelle  au magasin pour la faire tester
Répondre
#30
Est-ce que tu as le manuel de ton routeur ? L'as tu regardé la doc de ton routeur ?
-Fait un Restore to Factory Settings pour remettre le remettre en config usine ...
-Est-ce que tu as a suivi la doc pour assigné la 1ere adresse additionnel via ETS puis les suivante via l'interface WEB ?

Ne fait pas l'erreur de ne pas lire et de ne pas suivre le manuel, même les plus avertis des gens travaillant dans le KNX doivent suivre les manuel tant les procédures de mise en service de ce type de produit diffère d'un fabriquant a l'autre.
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#31
(20/08/2021, 08:55:32)filou59 a écrit : Est-ce que tu as le manuel de ton routeur ? L'as tu regardé la doc de ton routeur ?
-Fait un Restore to Factory Settings pour remettre le remettre en config usine ...
-Est-ce que tu as a suivi la doc pour assigné la 1ere adresse additionnel via ETS puis les suivante via l'interface WEB  ?

Ne fait pas l'erreur de ne pas lire et de ne pas suivre le manuel, même les plus avertis des gens travaillant dans le KNX doivent suivre les manuel tant les procédures de mise en service de ce type de produit diffère d'un fabriquant a l'autre.

Merci encore pour les conseils, que j'ai hélas déjà appliqué
C'est suite au reset factory que le composant se retrouve avec l'adresse 15.15.0 et que je ne sais plus changer Sad


Je viens de tester mon module chez le vendeur, et avec mon pc donc mon ets, ca fonctionne, alors qu'en rentrant à la maison ca ne fonctionne toujours pas, alors que la passerelle IP est seule sur le bus.
Dernière possibilité pour moi, c'est mon reseau (IP) qui parasite, je vais essayer de voir de ce côté là ce weekend
Répondre
#32
Dans 99% des cas ce genre de prb ne vient pas du matériel, soit les gens ne lisent pas le manuel, soit la manip n'est pas suivi a la lettre et un étape est zappé par exemple, parfois on est persuadé de savoir faire et on commet a chaque foi la meme erreur, soit un manque de connaissance de base niveau réseau complique la chose.


Citation :Dernière possibilité pour moi, c'est mon reseau (IP) qui parasite

Il te faut la 1ere fois un serveur DHCP, si tu as le net ta box rempli cette fonction.
1: Reset Usine
2: Insertion du participant dans ton projet 1.1.0
Etape Facultative mais recommandé : 
Ensuite, au niveau de ton participant (Routeur) tu désactive la fonction DHCP sous ETS et tu définis les paramètres réseau conforme a ce que tu as chez toi.

3: Assignation d'une adresse physique : Sous ETS Telecharger adresse individuelle ensuite appuie sur le bp de prog du routeur
4: Reglage des différent parametre sous ETS si besoin de les changer
5: Download application si tous les Flag de ton routeur sous ETS ne sont pas vert
6: Dans longlet BUS sous ETS sur l'interface actuelle, definir l'adresse individuelle 1.1.241  (Chapitre 5.5 de ton manuel)

Exemple : 
   
On voie ici 1.1.0 l'adresse d'un routeur, et 1.1.241 la 1ere adresse virtuel utilisé pour ETS pour la programmation.

7: Assignation des adresses de Tunnel via interface WEB, attention l'interface web est bloqué après Xmin par sécurité, il faut regarder dans la notice de ton produit comment on la débloque apres le temps imparti, parfois on peut associé une GA a un objet du routeur pour réactiver l'interface, parfois c'est via un bouton sur l'interface ...
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#33
Merci pour ton explication, hélas ce ne fonctionne toujours pas

Par contre une fois que le module à une ip fixe, si je relie directement le module au PC via un câble réseau cela fonctionne Smile

Il y adonc quelque chose sur mon réseau qui perturbe le module ou ETS.

En tout cas à présent j'ai une solution, c'est le principal, on a pas un nouveau module à installer tous les jours

Merci de votre aide à tous
Répondre
#34
Quel est ta config réseau :
1: Présence d'une box ADSL/Fibre
2: Liaison Box/Switch/PC/Routeur
3: Quels équipement réseau as tu ?
4: Adresse IP de ton Réseau (Box : IP/Masque..., Plage pour le DHCP)

Est-ce que tu es sur d'avoir attribué les bon parametre réseau a ta passerelle (IP Libre non utilisé, masque ...)
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#35
Bonjour,

vous n'auriez pas une box domotique qui tourne en parallèle et qui utilise la passerelle IP avec l'adresse 15.15.255 (Home Assistant, Jeedom, KNXd, EIBd, etc.) ?
J'ai eu le problème avec Jeedom provoquait le même défaut sur certains participants !
_______________________________________________________
Full KNX, même la sonnette ! - DOMOVEA V1 - JEEDOM - Home Assistant  Wink
Répondre
#36
(22/08/2021, 16:18:39)Nitro24 a écrit : Bonjour,

vous n'auriez pas une box domotique qui tourne en parallèle et qui utilise la passerelle IP avec l'adresse 15.15.255 (Home Assistant, Jeedom, KNXd, EIBd, etc.) ?
J'ai eu le problème avec Jeedom provoquait le même défaut sur certains participants !

Bonjour,

non pas de box domotique ...
Répondre
#37
(22/08/2021, 09:07:19)filou59 a écrit : Quel est ta config réseau :
1: Présence d'une box ADSL/Fibre
2: Liaison Box/Switch/PC/Routeur
3: Quels équipement réseau as tu ?
4: Adresse IP de ton Réseau (Box : IP/Masque..., Plage pour le DHCP)

Est-ce que tu es sur d'avoir attribué les bon parametre réseau a ta passerelle (IP Libre non utilisé, masque ...)

Une box adsl (192.168.1... sur laquelle j'ai un routeur configurer en 192.168.0 et sur leque j'ai un switch. 
L'interface ip est branchée sur le switch derrière le routeur elle a donc une IP en 192.168.0.X

La passerelle IP/KNX fonctionne parfaitement tant qu'i lne s'agit pas d'attribuer une nouvelle adresse physique à un participant.
La passerelle est configurée comme suit : 
IP : 192.168.0.4
Masque : 255.255.255.0
Gateway : 192.168.0.1

L'ip 0.4 est réservée sur le DHCP pour cette MAC adresse du temps ou la passerelle était en DHCP afin qu'elle garde à coup sur la même IP. Cette IP ne sera donc jamais donnée à un autre élément du réseau.
Répondre
#38
Ton PC est connecté comment à ton réseau, filaire ou wifi ?
_______________________________________________________
Full KNX, même la sonnette ! - DOMOVEA V1 - JEEDOM - Home Assistant  Wink
Répondre
#39
(24/08/2021, 10:00:25)Nitro24 a écrit : Ton PC est connecté comment à ton réseau, filaire ou wifi ?

en wifi
Répondre
#40
Tu ne serais pas sur le wifi de la box ?
Ce qui fait que, d après ton explication, il y a un routeur entre ton PC et le switch qui alimente la passerelle KNX.
Ton PC est en 192.168.1.x et ta passerelle en 192.168.0.4 ?
_______________________________________________________
Full KNX, même la sonnette ! - DOMOVEA V1 - JEEDOM - Home Assistant  Wink
Répondre
#41
(25/08/2021, 22:52:28)Nitro24 a écrit : Tu ne serais pas sur le wifi de la box ?
Ce qui fait que, d après ton explication, il y a un routeur entre ton PC et le switch qui alimente la passerelle KNX.
Ton PC est en 192.168.1.x et ta passerelle en 192.168.0.4 ?

J'ai désactivé le wifi de la box et tout mes appareils sont sur le wifi du routeur en 192.168.0.x dommage ....
Répondre
#42
C'est vrai que ta déscription ma moi aussi laissé un peu perplexe.


Citation :Une box adsl (192.168.1... sur laquelle j'ai un routeur configurer en 192.168.0 et sur leque j'ai un switch. 
L'interface ip est branchée sur le switch derrière le routeur elle a donc une IP en 192.168.0.X

La passerelle IP/KNX fonctionne parfaitement tant qu'i lne s'agit pas d'attribuer une nouvelle adresse physique à un participant.
La passerelle est configurée comme suit : 
IP : 192.168.0.4
Masque : 255.255.255.0
Gateway : 192.168.0.1

L'ip 0.4 est réservée sur le DHCP pour cette MAC adresse du temps ou la passerelle était en DHCP afin qu'elle garde à coup sur la même IP. Cette IP ne sera donc jamais donnée à un autre élément du réseau.


Box ADSL : 192.168.1.X (Quel Opérateur ?)
Routeur 192.168.0.X : Quel modele ? C'est quoi ce routeur il te sert a quoi ?  (Il est configuré comment ? Mode Bridge/Mode Routeur )

Tu as donc 2 routeur en serie !! C'est bien ca ?
Si c'est ca on va dire que Routeur 1 = BOX

Dans la majorité des cas c'est la box qui sert de routeur.
Selon les box et donc selon les opérateur, il n'est parfois pas possible d'utiliser de configurer la box en mode Bridge, si on se retrouve dans cette situation on a 2 routeur en serie qui vont devoir faire du double nat ce qui est pas tip top et ce qui peut poser parfois des problèmes (par exemple avec certaines console ...)

Ce genre d'usage est réservé normalement a des connaisseurs ou a des usages bien précis, car il faut savoir ce que l'on fait et maitrisé un minimum la partie réseau.

Moi je suis chez Orange, je ne souhaite pas utilisé ma box pour la partie routage, ni pour le wifi, j'ai souhaite maitriser la config firewalll, la partie VPN pour les connexion entrante j'ai donc un routeur deriere la box , ensuite j'ai des point d'acces WIFI deriere mon routeur ....


Si ton PC est branché deriere le 2nd Routeur et que tu branches ta passerelles IP/KNX deriere Routeur 1, c'est dans ce cas tout ca fait normal que tu ne puisses pas y acceder.
C'est pas impossible, mais il va falloir faire des regles de routage ...


Il faut que ton PC et que ton Interface IP soit deriere le meme routeur , donc derierer Routeur 2.

PS: Un conseil, indique les adresse IP compléte de tes équipement, une adresse est composé de 4 nombre séparé par un point, si il en manque un , on peut se demander si c'est une erreur, ou si comme dans ton cas la config semble sortir de l'ordinaire cela pourrait nous permettre de mieux comprendre.
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#43
(27/08/2021, 18:16:04)filou59 a écrit : C'est vrai que ta déscription ma moi aussi laissé un peu perplexe.


Citation :Une box adsl (192.168.1... sur laquelle j'ai un routeur configurer en 192.168.0 et sur leque j'ai un switch. 
L'interface ip est branchée sur le switch derrière le routeur elle a donc une IP en 192.168.0.X

La passerelle IP/KNX fonctionne parfaitement tant qu'i lne s'agit pas d'attribuer une nouvelle adresse physique à un participant.
La passerelle est configurée comme suit : 
IP : 192.168.0.4
Masque : 255.255.255.0
Gateway : 192.168.0.1

L'ip 0.4 est réservée sur le DHCP pour cette MAC adresse du temps ou la passerelle était en DHCP afin qu'elle garde à coup sur la même IP. Cette IP ne sera donc jamais donnée à un autre élément du réseau.


Box ADSL : 192.168.1.X (Quel Opérateur ?)
Routeur 192.168.0.X : Quel modele ? C'est quoi ce routeur il te sert a quoi ?  (Il est configuré comment ? Mode Bridge/Mode Routeur )

Tu as donc 2 routeur en serie !! C'est bien ca ?
Si c'est ca on va dire que Routeur 1 = BOX

Dans la majorité des cas c'est la box qui sert de routeur.
Selon les box et donc selon les opérateur, il n'est parfois pas possible d'utiliser de configurer la box en mode Bridge, si on se retrouve dans cette situation on a 2 routeur en serie qui vont devoir faire du double nat ce qui est pas tip top et ce qui peut poser parfois des problèmes (par exemple avec certaines console ...)

Ce genre d'usage est réservé normalement a des connaisseurs ou a des usages bien précis, car il faut savoir ce que l'on fait et maitrisé un minimum la partie réseau.

Moi je suis chez Orange, je ne souhaite pas utilisé ma box pour la partie routage, ni pour le wifi, j'ai souhaite maitriser la config firewalll, la partie VPN pour les connexion entrante j'ai donc un routeur deriere la box , ensuite j'ai des point d'acces WIFI deriere mon routeur ....


Si ton PC est branché deriere le 2nd Routeur et que tu branches ta passerelles IP/KNX deriere Routeur 1, c'est dans ce cas tout ca fait normal que tu ne puisses pas y acceder.
C'est pas impossible, mais il va falloir faire des regles de routage ...


Il faut que ton PC et que ton Interface IP soit deriere le meme routeur , donc derierer Routeur 2.

PS: Un conseil, indique les adresse IP compléte de tes équipement, une adresse est composé de 4 nombre séparé par un point, si il en manque un , on peut se demander si c'est une erreur, ou si comme dans ton cas la config semble sortir de l'ordinaire cela pourrait nous permettre de mieux comprendre.

Bonjour,

En effet ce n'est pas très clair je recommence Wink

J'ai une Box Proximus (Belgique) qui n'est pas top donc j'ai quasiment tout désactivé: Wifi, ... Sont branché sur cette BOX uniquement le décodeur de la TV ainsi que le routeur n°2 : TPLink Archer AX50 configuré en mode routeur et connecté en PPOE
Le réseau du routeur 2 est en 192.168.0.X
Tout mes appareils sauf le décodeur de la TV sont sur ce routeur soit en wifi soit en filaire, ils ont donc tous une IP en 192.168.0.X
Le PC : 192.168.0.44
La passerelle KNX : 192.168.0.4

J'accède depuis le PC sans aucun problème à la passerelle : 
- Accès au serveur Web se trouvant sur le port 8080
- Programmation des participants via ETS

La seule chose qui foire c'est donner une adresse physique à un participant. Il faut maintenant que je câble le PC sur la passerelle en direct sans passer par le réseau. C'est pourquoi j'ai configuré la passerelle en IP fixe ainsi que l'interface ethernet du PC.
Ce qui me fait dire que quelque chose sur le réseau perturbe ETS.

Ceci dit étant donné que l'ajout de participant est la seule chose qui ne fonctionne pas mais qu'on le fait plutôt rarement ce workaround me convient.

Merci à toi d'avoir tenté de me trouver des solutions Smile
Répondre
#44
Bonjour,

ta deuxième explication est plus compréhensible. J'ai moi-même utilisé le même type d'architecture et il n'y a pas de raison que ton routeur IP/KNX ne fonctionne pas.
A part ton PC avec ETS, tu n'a pas un autre client qui utilise la passerelle KNX ?
Question subsidiaire, les moniteurs de groupe et de bus fonctionnent-ils avec ta passerelle ?
_______________________________________________________
Full KNX, même la sonnette ! - DOMOVEA V1 - JEEDOM - Home Assistant  Wink
Répondre
#45
(30/08/2021, 18:59:13)Nitro24 a écrit : Bonjour,

ta deuxième explication est plus compréhensible. J'ai moi-même utilisé le même type d'architecture et il n'y a pas de raison que ton routeur IP/KNX ne fonctionne pas.
A part ton PC avec ETS, tu n'a pas un autre client qui utilise la passerelle KNX ?
Question subsidiaire, les moniteurs de groupe et de bus fonctionnent-ils avec ta passerelle ?
Le moniteur de groupe fonctionne mais pas le moniteur de bus : L’interface ne prend pas en charge le mode de connexion.
Répondre
#46
(31/08/2021, 19:08:51)ocrv a écrit :
(30/08/2021, 18:59:13)Nitro24 a écrit : Bonjour,

ta deuxième explication est plus compréhensible. J'ai moi-même utilisé le même type d'architecture et il n'y a pas de raison que ton routeur IP/KNX ne fonctionne pas.
A part ton PC avec ETS, tu n'a pas un autre client qui utilise la passerelle KNX ?
Question subsidiaire, les moniteurs de groupe et de bus fonctionnent-ils avec ta passerelle ?
Le moniteur de groupe fonctionne mais pas le moniteur de bus : L’interface ne prend pas en charge le mode de connexion.
Idem pour moi : pas de moniteur de bus avec mon Interface Siemens 148/22.
Répondre
#47
La fonction moniteur de bus est incompatible avec certains produits.

-Toutes les interfaces KNX/USB : Sont compatible.
-Interface KNX/Ethernet : Ca dépend peu etre des modeles, mais il me semble que le moniteur de bus n'est pas pris en charge d'une maniere gnl
-Routeur KNX/Ethernet : De base en se connectant avec sur le routeur on risque d'avoir le même prb. Mais il suffit de choisir l'interface réseau de votre PC qui elle va récupérer les donnée du routeur via l'adresse reservé au KNX : 223.0.23.12
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#48
(16/06/2021, 15:15:50)ocrv a écrit : Lorsque je veux télécharger l'adresse dans le participant j'obtiens le message d'erreur : "Plus d'un participant est en mode programmation"

Si j'utilise le diagnostic "Adresse individuelle --> mode de programmation" il m'en trouve un mais entre () *4 --> 15.15.255 (*4), parfois *3

le fais d'avoir cette astérix, c'est souvent une boucle sur le bus, les télégrammes tourne en boucle et ça re repette indéfiniment, et ça "voit" ton élément plusieurs fois...

faut revoir le câblage pour éliminé cette boucle..
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)