Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Config Crepuscule VR
#1
Bonjour à tous,

Après un looooong moment d'absence, j'ai enfin emmenagé. Bon tout n'est pas terminé (notamment les sols parce que chape anhydrite pas seche) mais passons, je suis sur place et c'est bien plus simple pour tout parametrer !

Et que serait une programmation sans soucis ! 
Et oui, je rencontre un petit soucis que je ne comprends pas.
J'ai une station météo Jung WSU2225
J'ai un controleur de VR ABB JRA/S8.230.5.1

Jusqu'à là, tout va bien !
J'ai donc parametré le detecteur crepusculaire de la station comme indiqué ici, avec une valeur limite active à 100lux.
   
   

La doc du JRA indique qu'un 0 entrainera une montée des VR et qu'un 1 entrainera une descente.
   

J'ai donc créé cette GA
   

Mais cela ne fonctionne pas, aucune réaction des 2 VR concernés Sad
Quelqu'un aurait une idée de où ca bloque svp ?

Merci Smile
Répondre
#2
Peut-être pas le bon objet lié à la GA dans le JRA ?
Le perfectionnement de soi et l'accession à sa légende personnelle passe obligatoirement par le partage de son savoir et de son expérience avec les profanes en demande d'initiation. (R. Bach)
Répondre
#3
(16/12/2020, 11:52:17)pollux06 a écrit : Peut-être pas le bon objet lié à la GA dans le JRA ?

Je pense que si, c'est les mêmes objets que j'utilise pour monter/descendre via un interrupteur

   
Répondre
#4
Tu es sûr que ta valeur limite de la station envoie bien un "0" ou un "1" ?
Il y a peut-être un autre paramètre à activer pour que l'information soit bien envoyée ?
Répondre
#5
(16/12/2020, 12:23:13)Maitre_Poulpi a écrit : Tu es sûr que ta valeur limite de la station envoie bien un "0" ou un "1" ?
Il y a peut-être un autre paramètre à activer pour que l'information soit bien envoyée ?

Bah j'ai configuré en "Depassement Val limite = ARRET, sous depasse + hyst = rien" donc ca devrait envoyer le 0 attendu au moment ou l'on dépasse 100lux mais ca marche pô Sad

Ca fait 3 jours que je cherche pourquoi ca marche pas  Blush Confused
Répondre
#6
Salut

Déjà dans ce genre de situation la 1ere chose a vérifier c'est le test de la GA.
En mode Diag dans le moniteur de bus tu envoie 1 ou 0 sur 1/1/2 et tu regardes si ca bouge.

Une fois que tu as validé ce 1er point, tu prends la partie Station méteo. Tu regardes la doc et tu étudie la logique.

Moi j'utilise 2 Valeur Limite avec des seuils différent , 1 pour la monter et l'autre pour la descente.
En plus celui de la descente je le couple a un horaire pour éviter de refermer les VR en journée si il fait trop sombre (Lors de Salle journée, orage...)

Voilà celle pour abaisser les VR il me semble :
   

J'utilise ensuite une Porte logique dans la station avec une info provenant d'un créneau horaire qui autorise la fermeture des VR (A partir de 16h par exemple)
KNX Partner Base / Avancé

Ma boite de MP est pleine, merci de créé un post si vous avez une question, cela profitera a tout le monde.
Répondre
#7
Cherche pas ...... regarde dans ta config de valeur limite : tu as coché non sur Envoyer si modification de la valeur.
Ton cyclique doit être à 0 mais tu dois envoyer le télégramme en cas de dépassement du seuil lumineux .... donc coche OUI
Le perfectionnement de soi et l'accession à sa légende personnelle passe obligatoirement par le partage de son savoir et de son expérience avec les profanes en demande d'initiation. (R. Bach)
Répondre
#8
Ah bah ouais mais là, s'ils font des blagues !

Je vais essayer ça pour demain matin !

Merci les gars Smile
Répondre
#9
Bon c'est bon ca fonctionne bien !
Par contre j'ai reflechi à ton système pour le mettre en place filou59, mais je me heurte à une problèmatique sequentielle.

Je m'explique :
J'ai créé une fonction sur le ABA S1.2.1 qui s'appelle "CONTEXT CREPUSCULE" qui active une sortie à 1 lorsque je suis entre 16h30 et 9h00

Sur la station météo, j'ai créé les 2 Valeurs limites qui fonctionnent bien pour monter/descendre les VRs (ca fonctionne si je lis a mes GA de VR)
J'ai créé une fonction logique ET sur la station qui utilise la VL2 (fermeture par exemple pour avoir un 1) pour ensuite avoir un 1 en sortie si VL2 est actif et CONTEXT_CREPUSCULE également. Ca fonctionne bien quand je mets la repetitivité de l'envoie pour les tests, mais je l'ai enlevée pour ne pas saturer le bus.
J'ai également créé une 2e fonction logique ET qui utilise la VL2 (ouverture par un 0) avec une inversion NOT(NOT(VL2).CONTEXT_CREPUSCULE)=SORTIE2. Idem pour la repetitivité.

J'ai une GA d'ouverture crepuscule des 3 VRs de la pièce principale
J'ai une GA de fermeture crepuscule de tous les VRs de la maison, sauf 1.

La vous m'avez vu arriver, j'ai donc lié ma sortie logique 1 a la fermeture crepuscule des VRs (via un 1) et lié ma sortie logique 2 à ma GA d'ouverture crepuscule.
Et là c'est simple, y a forcement un truc qui va pas. Comme c'est la même entrée qui gère montée/descente sur le controleur de VRs, si je suis en fermture crepuscule, j'ai donc un 1 a ma sortie logique, tout va bien, ca se ferme.
MAIS ! Mon autre sortie logique n'etant pas valide car la valeur limite est fausse. Donc mon ET logique NOT(NOT(VL2).CONTEXT_CREPUSCULE)=SORTIE2 fait donc NOT(NOT(1).1)=1
Donc forcement si ma sortie2 n'est pas valable, je vais recuperer un 1 dans tous les cas.
Et la vous voyez le drame arriver ?
Bah oui, mon 1 est envoyé dans ma GA d'ouverture crepuscule (qui contient 3 VRs, dont celui qui n'était pas contenu dans l'autre GA), resultat : le dernier VR ouvert post couché du soleil, se ferme.
Du coup je me demande comment gérer au mieux ce type de fonctionnement en respectant les bonnes pratiques ? parce que dans les faits, meme avec 2 Valeurs limites distinctes et 2 fonctions logiques distinctes, on interragit l'une avec l'autre.. Sad

Merci de m'avoir lu jusqu'au bout !
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)