Note de ce sujet :
  • Moyenne : 5 (1 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Automate WAGO 750-889 KNX
#26
Bon je viens de reprendre un programme fonctionnel et ai tout adapté avec ma version complète (config hardware, Macros KNX) et tout refait coté ETS avec le plug-in.
Je dois dire que maintenant j'ai de l'entrainement, je ne fais que ça depuis plusieurs heures.

Et avec cette base là, ça marche !!
Je ne sais pas ce qui ne fonctionne pas dans mon autre projet, mais c'est lié au projet. Peut-être une bibliothèque, j'en sais rien...

En tout cas, ça fonctionne !
Problème résolu !
Répondre
#27
J'ai pas de boulle de cristal Big Grin , donc a moins de mettre en ligne ton programme ca va etre dur de trouver le pourquoi du comment
KNX Partner Base / Avancé
Répondre
#28
Hello, je reviens à la charge...

Je pense avoir pas mal avancé et voici le projet Codesys et le projet ETS5 dont je vais parler.
Les modules ne sont pas tous complets (Eclairage_Tempo, seche_serviette notamment) mais la base est là et ça m'a permis d'avancer dans ETS5 pour faire les premiers tests.

Ce qui fonctionne :
  • Les FbDPT_Switch (M1_001 à M1_012)
  • FbKNX_Eclairage : en tout cas le détecteur de présence du local technique allume la lumière.
Ca veut donc dire que j'ai compris le Plug-in Wago, d'ailleurs l'import/export est une merveille !
J'ai aussi compris les adresses dwIndex_DPT qu'on retrouve dans l'export XML du Plug-in Wago. Ca permet de vérifier que ça peut communiquer.

Là où je bute c'est pour FbKNX_Blind_actuator_pro (que j'ai à peine adapté pour la lisibilité) : les commandes qui viennent du F50 (Jung) n'arrivent pas à l'automate. Dans ETS5, le mode diagnostic voit pourtant passer les infos avec la bonne source et la bonne destination.
J'ai aussi essayé avec la température fournie par le F50 pour le module seche_serviette mais ça n'arrive pas non plus.
Code :
(* Température *)
_02_Temperature(
    dwIndex_DPT    := idx2,
    bKNX_Master    := bKNX_Master,
    rValue_OUT    => rTemperature);
ou
Code :
(* Température *)
_02_Temperature(
    dwIndex_DPT    := idx2,
    bKNX_Master    := bKNX_Master);

IF _02_Temperature.xUpdate_PLC THEN
    rTemperature := _02_Temperature.rValue_OUT;
END_IF
ne fonctionne pas.

J'ai essayé d'activer le timeout de lecture à 5 secondes, mais ça n'a rien changé mis à par que le bit xTimeOut de l'instance _02_Temperature est passé à True.

Le test est fait dans la salle de bain du RDC ou SDB parents.
Avec le F50 du bureau ça ne fonctionne pas non plus.

Quelqu'un a une piste ?
Où est-ce que j'ai fait une boulette ?

Et par la même occasion, pour les volets roulants ou les BSO, les commandes courtes et longues correspondent à Move et Stop/step respectivement ou il faut une conversion ?

A+
Michel
Répondre
#29
Salut

1: Il y a un truc qui me choc dans ton projet ETS.
Le nom de tes objets ne correspond pas au nom de tes bloc fonctions dans Codesys

Je l'impression que tu as utilisé une methode de nommage a toi qui n'etait pas préconisé et qu'ensuite tu a changer tout ca en respectant les préconisation de WAGO.

Je te conseille de reprendre a 0, tu parques dans ETS le controleur actuel si tu veux l'avoir pour référence , tu en ajoutes un nouveau pour repartir sur une bonne base.
Ensuite refait tes affectation sous ETS avec les GA.

A mon avi le problème n'est pas là mais en faisant ca ca va te permettre de mieux t'y retrouver (ou que qq comme moi s'y retrouve)

2Big Grinans ton projet ETS je ne voie aucune GA vers tes Volets et BSO ?
je ne voie que 4 GA vers ton automate 0/0/1 0/1/0 0/1/1 0/1/2 ??? pour de l'eclairage , BP Sonnette et presence BEC
KNX Partner Base / Avancé
Répondre
#30
(11/05/2021, 09:36:18)filou59 a écrit : Salut

1: Il y a un truc qui me choc dans ton projet ETS.
Le nom de tes objets ne correspond pas au nom de tes bloc fonctions dans Codesys
J'ai pourtant fait comme c'est écrit dans toutes les doc Wago...

Dans CodeSys:
Code :
    M1_001_Presence_BEC                : FbDPT_Switch;
...
    M1_013_VR_salon                    : FbKNX_Blind_actuator_pro;
FbDPT_Switch est une fonction pour lire/écrire un bit KNX.
FbKNX_Blind_actuator_pro est une macro pour gérer les volets roulants ou BSO et contient :
Code :
_01_Move                   : FbDPT_UpDown;
_02_Stop_Step              : FbDPT_Switch;
_03_SafetyPosition         : FbDPT_Switch_pro;
_04_LockBlind              : FbDPT_Switch;
_05_SetPosition            : FbDPT_Switch;
_06_MoveToShadowPosition   : FbDPT_Switch;
_07_Feedback_Pos_Blind     : FbDPT_Scaling_pro;
_08_Feedback_Pos_Lamella   : FbDPT_Scaling_pro;

qui sont des fonction de lecture/écriture de bit ou de valeur de position.

Cette macro est fournie sur le site de Wago. Donc je pars du principe qu'elle respecte ce qui doit être respecté. L'instance de la macro est bien Mx_yyy_quelquechose, comme indiqué dans la doc.

Et la macro FbKNX_Eclairage fonctionne avec un détecteur de présence mais pas avec le F50.

(11/05/2021, 09:36:18)filou59 a écrit : Je l'impression que tu as utilisé une methode de nommage a toi qui n'etait pas préconisé et qu'ensuite tu a changer tout ca en respectant les préconisation de WAGO.
Qu'est-ce qui te fait penser ça ? Ca m'intrigue...
Le coté Wago (CodeSys) est donc bon selon toi ? C'est dans ETS que ça ne va pas ?

(11/05/2021, 09:36:18)filou59 a écrit : Je te conseille de reprendre a 0, tu parques dans ETS le controleur actuel si tu veux l'avoir pour référence , tu en ajoutes un nouveau pour repartir sur une bonne base.
Ensuite refait tes affectation sous ETS avec les GA.

A mon avi le problème n'est pas là mais en faisant ca ca va te permettre de mieux t'y retrouver (ou que qq comme moi s'y retrouve)
Euh... je m'y retrouve bien. En triant par nom, tout est structuré comme dans le programme CodeSys.

(11/05/2021, 09:36:18)filou59 a écrit : 2Big Grinans ton projet ETS je ne voie aucune GA vers tes Volets et BSO ?
je ne voie que 4 GA vers ton automate 0/0/1 0/1/0 0/1/1 0/1/2 ??? pour de l'eclairage , BP Sonnette et presence BEC
Pourtant :
[Image: GA.png]

Donc tu ne vois pas la même chose que moi ? Tout est affecté sauf "M1_007_Presence" que je vais sans doute faire autrement. Mais pour tester le BSO de la SDB des parents, tout est affecté. tu vois quoi, toi dans le projet ETS ?

Et le F50 dans la "SDB parents" est aussi affecté :
[Image: GA-F50.png]
Répondre
#31
Laisse tombé tu m'as pas envoyé le bon projet ETS, c'est pas la derniere version a mon avis.
KNX Partner Base / Avancé
Répondre
#32
En effet, je sais pas ce que j'ai foutu... je poste le bon projet tout à l'heure.
Répondre
#33
(11/05/2021, 00:45:34)MrWaloo a écrit : Je pense avoir pas mal avancé et voici le projet Codesys et le projet ETS5 dont je vais parler.

Les liens sont toujours les mêmes mais les fichiers sont à jour.
J'ai aussi rajouté l'export XML pour qu'on parle de la même chose si on en parle.

Bon alors : j'ai mis CodeSys et les configurations ETS en allemand, parce que les traductions sont moisies et que je comprends très bien l'allemand. Ne vous inquiétez pas, ce n'est pas un bug ;-)

Config du F50 : 
[Image: GA-F50.png]

C'est la 3ème ligne du F50 (Wippe 3) qui pilote le BSO de la SDB :
- 2/0/6 : impulsion longue "Move"
- 2/1/6 : impulsion courte "Stop / step"

J'ai aussi testé avec les flags R sur les 2 dernières lignes : pas mieux.

Le F50 envoie effectivement les infos sur le bus :
[Image: debug-F50.png]

Le bloc du BSO de la SDB est configuré comme ça :
[Image: config-BSO-SDB.png]

On voit que les 2 premières infos sont bien adressées.

J'ai aussi essayé en mettant le BP 1 du F50 (1/0/12) vers le signal simple de présence (M1_005_Presence) l'automate n'a rien vu.

Par contre le détecteur de présence du local technique, lui fonctionne nickel. Toute la chaine fonctionne jusqu'à la sortie automate.
Répondre
#34
(11/05/2021, 21:23:31)MrWaloo a écrit : Les liens sont toujours les mêmes mais les fichiers sont à jour.
J'ai aussi rajouté l'export XML pour qu'on parle de la même chose si on en parle.
Ca va tout de suite mieux avec le bon projet Big Grin


(11/05/2021, 21:23:31)MrWaloo a écrit : Bon alors : j'ai mis CodeSys et les configurations ETS en allemand, parce que les traductions sont moisies et que je comprends très bien l'allemand. Ne vous inquiétez pas, ce n'est pas un bug ;-)
Pour les Application style Codesys je travaille toujours en Anglais moi par habitude.

Pour ETS Je suis un peu surpris car les traductions Jung sont pour moi très parlante, je n'ai remarqué aucun problème.
Tu as des exemples ?

(11/05/2021, 21:23:31)MrWaloo a écrit : Config du F50 : 
Pour faire gagner du temps, indique aussi l'adresse physique du participant.

(11/05/2021, 21:23:31)MrWaloo a écrit : Le F50 envoie effectivement les infos sur le bus :
OK Bon reflexe le moniteur de groupe, le problème ne vient pas de ton F50.
Coté ETS et config WAGO c'est OK aussi.

Dans tous les cas, en cas de doute il suffit d'envoyer les ordre sur les GA via ETS.


Petite question : As-tu bien fait un Telechargement Application de ton controler (1.0.1)

(11/05/2021, 21:23:31)MrWaloo a écrit : J'ai aussi essayé en mettant le BP 1 du F50 (1/0/12) vers le signal simple de présence (M1_005_Presence) l'automate n'a rien vu.
A chaque modification coté ETS il faut envoyer les modif dans la borne KNX de ton automate, c'est bon tu y penses a chaque foi ?
Je préfere poser la question tout suite que de risquer de tourner en rond pour une broutille.
KNX Partner Base / Avancé
Répondre
#35
(13/05/2021, 09:04:51)filou59 a écrit : Pour faire gagner du temps, indique aussi l'adresse physique du participant.
OK, j'y penserai.

(13/05/2021, 09:04:51)filou59 a écrit : OK Bon reflexe le moniteur de groupe, le problème ne vient pas de ton F50.
Je suis automaticien, j'ai les bons réflexes ;-)

(13/05/2021, 09:04:51)filou59 a écrit : Coté ETS et config WAGO c'est OK aussi.
C'est aussi ce que je pense, mais pourtant...

(13/05/2021, 09:04:51)filou59 a écrit : Dans tous les cas, en cas de doute il suffit d'envoyer les ordre sur les GA via ETS.
Bon conseil !
Je viens de forcer toutes les GA pour l'éclairage et tous mes relais sont enclenchés...
J'ai essayé avec un VR, la commande de montée/descente fonctionne : les relais s'enclenchent et l'automate revoie la position sur le bus toutes les x secondes durant le mouvement.
Quand je force l'alarme vent (6/0/7) l'automate voit l'info. Quand c'est remis à 0 par la station météo, l'automate ne réagit pas mais je vois passer l'info dans le diagnostique.
Ca peut être un problème de routage de certaines adresses du bus TP vers IP ?

(13/05/2021, 09:04:51)filou59 a écrit : Petite question : As-tu bien fait un Telechargement Application de ton controler (1.0.1)
...
A chaque modification coté ETS il faut envoyer les modif dans la borne KNX de ton automate, c'est bon tu y penses a chaque foi ?
Je préfere poser la question tout suite que de risquer de tourner en rond pour une broutille.
Oui, j'y pense et je sais que c'est bien envoyé parce qu'une relecture de l'automate via ETS montre les bonnes GA aux bons endroits.



Ce qui me perturbe c'est que :
- le programme a l'air OK,
- en mode diagnostique ETS me montre les GA, donc la carte 646 voit bien les GA changer d'état
mais que le programme ne réagit pas dans certains cas...

J'ai la même config dans 3 pièces :
- local technique
- WC RDC
- WC 1er
La config c'est un détecteur de présence Luxomat qui pilote une lumière. Donc c'est le même bloc dans l'automate.
Pourtant :
- local technique : ok
- WC RDC : ok
- WC 1er : PAS ok !

Franchement, je suis largué : ça ne réagit pas de manière logique.

Merci pour ton temps :-)
Répondre
#36
Si j'ai bien compris l'histoire des adresses c'est comme ça qu'on peut représenter les choses :
[Image: Routage-KNX.png]

Sur le réseau IP, comme le contrôleur est KNX-IP, il a une adresse KNX : 1.0.1
Sur le réseau TP, la carte a l'adresse 1.1.0
En interne, le réseau TP a une adresse 1.1.254 qui sert de routeur vers le réseau IP.
J'ai bon ?



Sur la page du contrôleur, à l'onglet KNX j'ai ça :
[Image: Config-KNX.png]

Dans le debug, quand je change une AG, l'adresse de source est 1.1.254
Quand c'est l'automate qui envoie une info, la source est 1.0.1



Dans ETS c'est comme ça :
[Image: ETS-Routeur.png]

Tout ça c'est bon ?
Répondre
#37
Le FbKNX_Eclairage c'est toi qui l'a fait ?
Je me demande si le problème vient pas de là.

Car si c'est le cas commencer directement (ou presque) en utilisant ces propres bloc, c'est peu être bruler les étapes.
Moi je n'en ai jamais eu besoin, j'ai juste créé des FB pour des DPT qui n'existait pas. Mais j'ai juste fait du copier collé et de l'adaptation de nom pour que le bon type soit reconnu dans le plugin sous ETS.

Sinon je voie 2 autres facon de faire :
1:Ton detecteur de présence envoie une info binaire, tu utilises ca : FbKNX_BinaryInput_Switch
Ensuite tu pilotes ta sorties comme tu le souhaites.
C'est du basic de chez basic mais ca doit marcher.

L'inconvénient en faisant ca c'est que tu ne gere pas ton eclairage coté KNX.

2:Utilise le FbKNX_Switch_actuator pour gérer ton eclairage.
Par exemple pour les WC du 1er, tu fait pointer ton detecteur et l'objet switch de ce FB sur 1/0/17, le retour feedback en 1/1/17.
Ca doit fonctionner.

Pense a bien déclarer les variables du style : typSwitchChannel / typConfigBlind ... qui sont utilisé dans les FB KNX en RETAIN PERSISTENT, ca permet de mémoriser les état entre 2 chargements de programme ou après coupure de jus...

Ces variables sont aussi a paramétrer parfois, pour tes VR/BSO par exemple il faudra y mettre tes tps de courses....
Pour de l'éclairage on peut y paramétrer le mode de fonctionnement par exemple, (Normal, type cage escalier etc...)
KNX Partner Base / Avancé
Répondre
#38
(13/05/2021, 11:35:49)filou59 a écrit : Le FbKNX_Eclairage c'est toi qui l'a fait ?
Je me demande si le problème vient pas de là.
Oui c'est moi qui l'ai fait. Dans le genre simple, il est simple et fonctionne puisqu'en forçant les AG, le programme réagit correctement.

(13/05/2021, 11:35:49)filou59 a écrit : Car si c'est le cas commencer directement (ou presque) en utilisant ces propres bloc, c'est peu être bruler les étapes.
Moi je n'en ai jamais eu besoin, j'ai juste créé des FB pour des DPT qui n'existait pas. Mais j'ai juste fait du copier collé et de l'adaptation de nom pour que le bon type soit reconnu dans le plugin sous ETS.
J'ai fait pas mal d'essais avant et je ne débute pas en programmation. Et comme dit, ce FB fonctionne.

(13/05/2021, 11:35:49)filou59 a écrit : Sinon je voie 2 autres facon de faire :
1:Ton detecteur de présence envoie une info binaire, tu utilises ca : FbKNX_BinaryInput_Switch
Ensuite tu pilotes ta sorties comme tu le souhaites.
C'est du basic de chez basic mais ca doit marcher.

L'inconvénient en faisant ca c'est que tu ne gere pas ton eclairage coté KNX.
Certaines info de la station météo sont remontées avec juste le FbKNX_switch et ces info-là non plus ne fonctionnent pas.

(13/05/2021, 11:35:49)filou59 a écrit : 2:Utilise le FbKNX_Switch_actuator pour gérer ton eclairage.
Par exemple pour les WC du 1er,  tu fait pointer ton detecteur et l'objet switch de ce FB sur 1/0/17, le retour feedback en 1/1/17.
Ca doit fonctionner.

Pense a bien déclarer les variables du style : typSwitchChannel / typConfigBlind ... qui sont utilisé dans les FB KNX en RETAIN PERSISTENT, ca permet de mémoriser les état entre 2 chargements de programme ou après coupure de jus...

Ces variables sont aussi a paramétrer parfois, pour tes VR/BSO par exemple il faudra y mettre tes tps de courses....
Pour de l'éclairage on peut y paramétrer le mode de fonctionnement par exemple, (Normal, type cage escalier etc...)
J'ai regardé cette macro, elle est bien plus compliquée que la mienne et l'interface KNX est la même.
Répondre
#39
Citation :Certaines info de la station météo sont remontées avec juste le FbKNX_switch et ces info-là non plus ne fonctionnent pas.

Si tu prends par exemple 6/0/2 que tu envois un 1 ou 0 depuis ETS tu ne reçois pas l'info dans ton automate ?
Le statu de ton bloc KNXMaster est sur quoi ?
A la limite claque un bloc CTU sur la sortie "xUpdate_PLC" de certains bloc pour incrémenter un compteur afin de vérifier si tu recois ou non les telegrammes.
Je ne sais plus a quel niveau la table de filtrage du routeur intervient et si elle intervient pour le contrôleur lui même. 
Quand tu utilises de nouvelle GA, la 1ere fois envoi aussi l'appli dans le routeur qq fois que ca vienne de là.
KNX Partner Base / Avancé
Répondre
#40
(13/05/2021, 10:51:21)MrWaloo a écrit : (...)
Ca peut être un problème de routage de certaines adresses du bus TP vers IP ?
(...)
Quand j'ai une intuition, je la suis, c'est souvent la bonne voie.
J'ai repris la doc du starter kit 03 et y ai cherché la config du routeur. On y trouve figure 24 page 27 comment ça doit être configuré et ce n'est pas comme la config par défaut :
[Image: Config-routage-starter-kit.png]

J'ai donc corrigé en conséquence et chargé :
[Image: Config-routage-corrig-e.png]

Et tout s'est mis à fonctionner.



Explications (selon moi)

Comme on le voit sur le schéma suivant :
[Image: Routage-KNX.png]
Les GA sur le KNX TP doivent passer par le routeur pour arriver dans le contrôleur où le programme peut les lire et les traiter.
Si le routeur ne laisse pas passer les GA, le contrôleur est aveugle.
Une fois le routeur configuré correctement, tout va beaucoup mieux.

En tout cas, je suis bien content que ça fonctionne !
Répondre
#41
(11/08/2017, 22:12:25)filou59 a écrit : (...) il faut ajouter qq relais comme 788-304 (...)

Tu utilises quoi pour repérer ces relais ? Ils ont une encoche semblable à celle des bornes pour y encliqueter un repère, mais je n'ai pas trouvé de modèle de 15mm de large...
209-145 est le plus proche que j'ai trouvé, mais que 10 mm de large.
Le rouleau 2009-110 irait aussi mais c'est 50m... il ne m'en faudrait que 2m MAX...

Bientôt je me bricole un truc en papier/carton blanc sinon...
Répondre
#42
Etiquette brother de 12mm que je colle sur le relais. Ca permet d'avoir une bonne surface d'impression.

Sinon suivant la génération du support il y a 2 modele d'etiquette WAGO qui peuvent convenir.

Les anciens on peut clipser des etiquette de borne
Les nouveaux c'est de la bande a recouper.
J'ai pas les ref en tete.
KNX Partner Base / Avancé
Répondre
#43
Merci pour l'info !
Répondre
#44
Un petit retour sur la solution Wago 750-889 + 753-646 : de la balle !!!
On fait tout comme on veut, c'est formidable !

Exemple avec la gestion des volets et BSO :
J'ai adapté le module de gestion des volets et BSO proposé dans la bibliothèque Wago de sorte que les volets reviennent non pas en position haute mais à leur position initiale quand la position d'ombrage n'est plus demandée. La position d'ombrage n'est demandée que si la luminosité et la température extérieure dépassent une certaine valeur. Etc.
Bref, c'est de la programmation, donc si on peut décrire ce qu'on veut, c'est programmable.

Je ne regrette pas du tout mon choix.
Répondre
#45
(18/08/2021, 14:04:55)MrWaloo a écrit : Un petit retour sur la solution Wago 750-889 + 753-646 : de la balle !!!
On fait tout comme on veut, c'est formidable !

Exemple avec la gestion des volets et BSO :
J'ai adapté le module de gestion des volets et BSO proposé dans la bibliothèque Wago de sorte que les volets reviennent non pas en position haute mais à leur position initiale quand la position d'ombrage n'est plus demandée. La position d'ombrage n'est demandée que si la luminosité et la température extérieure dépassent une certaine valeur. Etc.
Bref, c'est de la programmation, donc si on peut décrire ce qu'on veut, c'est programmable.

Je ne regrette pas du tout mon choix.

l'avantage d'une solution orienter indus, c'est tellement flexible à souhait
Répondre
#46
Bonjour.

Je suis nouveau sur le forum mais pas inexpérimenté en terme de d'automatisation.
Je me permet de me greffer sur ton poste pour poser quelques question lié au module wago knx.

J'utilise tous les jours des automates wago dans mon boulot, plus généralement les 750-881 et étant sur un projet de construction d'une maison individuelle, je réfléchi donc à la meilleur solution domotique (pour mon cas).

Après avoir aidé mon frère pour la sienne, il a choisi les solution open source qui nécessite du wifi / zigbee/ ... de partout.
Cette solution ne me convient pas, je préférais rester sur du tout filaire autant que possible. J'ai tester des modules chinois de types KINCONY, le hardware est de bonne qualité mais le software est complétement pourri. Puis avec cette solution, on ce retrouve a devoir faire des mix de solutions qui n'en finisse plus et l'interconnection n'est pas des plus facile.

Puis est venu l'idée d'utiliser un automate wago (surtout que j'en est plein à dispo au boulot) en parallèle de Home Assistant + Nodered pour la parti supervision / contrôle.
Il répond a tous les critères et plus j'avance dans mes teste plus je trouve des module complémentaire intérressant.

Première question, le module 753-646 s'utilise t'il obligatoirement avec la CPU 750-889 ?
Je souhaiterais conserver une CPU de type 750-881 ou 750-890 que je touche à des tarifs plus abordable.

Le but serait de pouvoir d'avoir :
- un CPU 750-881 ou 890
- Carte 8 TC pour la gestion en cascade du plancher chauffant (je suis thermicien)
- X Carte 8 Entrées TOR
- X Cartes 8 Sorties TOR
- 1 Carte 750-653 RS485 pour le pilotage de la VMC DF
- 1 Carte 753-646 KNX

L'utilisation de la carte KNX a surtout pour but d'utiliser des capteurs de style station météo, luminosité EXT, ..., qui sont beaucoup mieux fini que les modèles fais pour l'opensource.

Que pensez-vous de cette solution ? J'espère avoir était claire dans ma demande ?

Si mon message dérange, je le déplacerais dans un catégorie approprié.

Merci d'avance, Quentin.
Répondre
#47
Bonjour

La carte 753-646 peut s'utiliser avec n'importe quel automate. WAGO appelle ca le mode device. 
Avec un 750-889 , on a en plus la possibilité d'avoir un fonctionnement type routeur KNX. C'est la grosse différence.

Le 750-881 ou 890 iront parfaitement, par contre tu sais que le 881 est arreté ?

Si j'ai un conseil a te donner, ne fait pas l'impasse sur les Boutons KNX, c'est vachement mieux qu'un bouton classique que tu câblerais sur une entrée TOR.

Bref le KNX apporte un gros plus en terme de Bouton, Detecteur de presence ....
KNX Partner Base / Avancé
Répondre
#48
En effet la carte 646 peut être utilisée avec n'importe quel automate, mais tu perds la fonctionnalité "routeur IP". Ce qui en soit n'est pas grave, il existe des routeurs IP plus performants par ailleurs. Avec une CPU 889 et Jeedom en permanence, impossible de connecter ETS en même temps. Donc un autre routeur n'est pas une mauvaise idée, c'est quelque chose que je ne savais pas au moment de l'achat.

Je rejoins tout à fait Filou59 quand à l'utilisation de boutons KNX. Tu n'auras qu'un câble à installer vers les BP, détecteurs de présence et autre appareils.
Il faut savoir que tu auras déjà plein de départs depuis ton tableau pour les lumières et éventuellement les volets roulants / BSO. Ne te rajoute pas encore des fils que tu peux si facilement remplacer par un seul câble. Perso j'ai un départ de câble KNX par étage + 1 vers le garage en réserve.

Ma config est très proche de ce que tu prévois, sauf que je n'ai qu'une carte de 4 DI "au cas où" et je n'en utilise qu'une pour forcer l'éclairage dans le local technique quand je bosse dans cette pièce et que je suis trop loin du détecteur de présence qui me perd de temps en temps.

J'ai aussi une carte de comm. RS485 pour la VMC DF (Brink Flair400), ça fonctionne très bien.

J'ai :
- CPU 750-889
- 2 cartes 2 AI PT100
- 2 cartes 653 (1 en réserve)
- carte de 8 potentiels 0V
- 8 x 8DO 24V
- carte de 8 potentiels 0V
- 2 x 8 DO 24V
- 1 x 4 DI 24V
- terminaison

Les relais que j'utilise sont des 788-304. Des peignes sont facilement trouvables 788-113 à 117 pour ponter les 0V (je les ponte par 8) ou le 230V. J'ai regroupé les relais qui pilotent des lumières sur un même circuit. C'est valable encore plus facilement pour les volets roulants et BSO. Les peignes peuvent se chevaucher pour avoir plus de 8 ponts.

J'ai aussi un petit 750-841 (pas sûr de la ref) pour le garage avec que des entrées et sorties pour les lumières et les portes de garage.
Répondre
#49
(23/10/2021, 12:26:53)filou59 a écrit : Bonjour

La carte 753-646 peut s'utiliser avec n'importe quel automate. WAGO appelle ca le mode device. 
Avec un 750-889 , on a en plus la possibilité d'avoir un fonctionnement type routeur KNX. C'est la grosse différence.

Le 750-881 ou 890 iront parfaitement, par contre tu sais que le 881 est arreté ?

Si j'ai un conseil a te donner, ne fait pas l'impasse sur les Boutons KNX, c'est vachement mieux qu'un bouton classique que tu câblerais sur une entrée TOR.

Bref le KNX apporte un gros plus en terme de Bouton, Detecteur de presence ....

Bonjour.

Merci de votre réponses.

Concernant le 881 je n'était pas au courant, j'en parlerai à mes collègues. Mais pour le moment, nous pouvons en commander, ce n'est pas un problème.
D'ailleurs les prix WAGO vont augmenter d'ici quelques temps, on à eu une note interne.

Concernant les interrupteurs KNX, j'en est déjà installé dans un ancien boulot. Pour la plupart, il sont très bien fini, la possibilité de les avoirs avec 6 touches, les BP sont plus silencieux, ...
Mais les prix restent dissuasif surtout que j'aimerais rester uniforme dans toutes la gamme d'appareillage.

Si vous connaissez des gammes complètent (avec RJ45 cat7, prises, inters et sortie de câble), dans un prix raisonnable, je reste à l'écoute.

Citation :
En effet la carte 646 peut être utilisée avec n'importe quel automate, mais tu perds la fonctionnalité "routeur IP". Ce qui en soit n'est pas grave, il existe des routeurs IP plus performants par ailleurs. Avec une CPU 889 et Jeedom en permanence, impossible de connecter ETS en même temps. Donc un autre routeur n'est pas une mauvaise idée, c'est quelque chose que je ne savais pas au moment de l'achat.


Je rejoins tout à fait Filou59 quand à l'utilisation de boutons KNX. Tu n'auras qu'un câble à installer vers les BP, détecteurs de présence et autre appareils.
Il faut savoir que tu auras déjà plein de départs depuis ton tableau pour les lumières et éventuellement les volets roulants / BSO. Ne te rajoute pas encore des fils que tu peux si facilement remplacer par un seul câble. Perso j'ai un départ de câble KNX par étage + 1 vers le garage en réserve.

Ma config est très proche de ce que tu prévois, sauf que je n'ai qu'une carte de 4 DI "au cas où" et je n'en utilise qu'une pour forcer l'éclairage dans le local technique quand je bosse dans cette pièce et que je suis trop loin du détecteur de présence qui me perd de temps en temps.

J'ai aussi une carte de comm. RS485 pour la VMC DF (Brink Flair400), ça fonctionne très bien.

J'ai :
- CPU 750-889
- 2 cartes 2 AI PT100
- 2 cartes 653 (1 en réserve)
- carte de 8 potentiels 0V
- 8 x 8DO 24V
- carte de 8 potentiels 0V
- 2 x 8 DO 24V
- 1 x 4 DI 24V
- terminaison

Les relais que j'utilise sont des 788-304. Des peignes sont facilement trouvables 788-113 à 117 pour ponter les 0V (je les ponte par 8) ou le 230V. J'ai regroupé les relais qui pilotent des lumières sur un même circuit. C'est valable encore plus facilement pour les volets roulants et BSO. Les peignes peuvent se chevaucher pour avoir plus de 8 ponts.

J'ai aussi un petit 750-841 (pas sûr de la ref) pour le garage avec que des entrées et sorties pour les lumières et les portes de garage.


Qu'entends-tu pas routeur IP ? Aujourd'hui quand je communique en modbus, je n'est aucun problème pour lire les variables.

Je programme pas directement par codesys ou e-cockpit. Je récupère directement les informations en modbus et je traite tout par Nodered qui me remonte les informations plus facilement sous Home Assistant.

Si je comprends bien, la carte KNX permet de lire le réseau bus et de le programmer, mais elle doit avoir obligatoirement avoir sa propre carte réseau ?
Donc un port Ethernet MODBUS et un port pour le KNX ? Par exemple, le PFC200 possède 2 cartes réseaux, cela pourrai solutionner le problème ?

Les entrées DI vont principalement me servir a faire remonter les informations des capteurs d'alarme. Je prévois de tout faire en filaire et les capteurs de tous de type TOR.

Pour en revenir aux interrupteurs, je suis d'accords avec vous, mais cela reste essentiellement un problème de coûts.
Les interrupteurs conventionnelle remplissent très bien cette taches et en câblage sa coute pas forcement plus chère.

Pareille, si tu connais des gammes équivalent au Schneider ODACE, je suis pas fermé à regarder.

Les entrées WAGO sont en 24VDC, donc vu qu'on est sur une tension de sécurité, je vais toutes les câbler en RJ45 Cat7.
J'ai eu les 1000m de RJ45 à 700euro. Ramené au au prix du mètre, le RJ soit moins chère que le BUS KNX.

Et pour réduire un peux les longueurs tirés, je peux créer des petites lignes à la manière  du BUS vu que j'ai 4 paires par câble ?
Répondre
#50
La serie 880 est train d'etre renouvelé car le processeur est arreté d'après mes info, donc a partir du moment ou il n'y a plus de puce plus de fabriquation possible, les seuls que tu pourras trouver ce sont les stocks.



Citation :Concernant les interrupteurs KNX, j'en est déjà installé dans un ancien boulot. Pour la plupart, il sont très bien fini, la possibilité de les avoirs avec 6 touches, les BP sont plus silencieux, ...

Mais les prix restent dissuasif surtout que j'aimerais rester uniforme dans toutes la gamme d'appareillage.

Oui mais honnêtement faire une install KNX sans BP KNX autant rien faire...

Hager/Schneider/MDT/ABB/Jung/Gira....

J'ai volontairement omis Legrand, tu peux faire une recherche sur le forum pour voir qu'on cite souvent cette marque pas forcément en bien pour ce type produit.

Moi je suis parti sur du Jung. Toute la gamme possible , mais je suis parti sur du Legrand sur tout ce qui est prise au ras du sol, elles sont toutes caché donc on s'en fou.

A noté qu'en france on a le format standard 45x45, qui autorise 4 a 6 BP , en allemange il sont sur du 50x50, donc ca ouvre la porte a des BP plus sympa avec jusqu'a 8BP.

Pour les prix, suffit de prendre la catalogue d'un fabriquant et d'utiliser ensuite un comparateur de prix.


Citation :Qu'entends-tu pas routeur IP ? Aujourd'hui quand je communique en modbus, je n'est aucun problème pour lire les variables.

Il va falloir que tu potasses le KNX pour apprendre pas mal de chose a mon avis.



En KNX a la base on a pas d'automate, il faut donc une interface pour se connecter sur le bus : USB/Serie/Ethernet 
De nos jour il faut partir sur des interface Ethernet, mais là on a 2 choix :
-Interface Ethernet/KNX
-Routeur Ethernet/KNX

Les 2 type de produits permette de se connecter sur un réseau filaire KNX (TP), le routeur permet en plus d'acceder a d'autre ligne KNX (a condition d'avoir un autre routeur qui constituerait une 2nd ligne)

Ce type de produit permet de paramétrer les participant KNX , mais aussi de récupérer les info qui passe sur le bus ou pour donner des ordre via un superviseur.



Citation :Je programme pas directement par codesys ou e-cockpit. Je récupère directement les informations en modbus et je traite tout par Nodered qui me remonte les informations plus facilement sous Home Assistant.
Tu ne mets aucun programme dans ton automate ? Alors pourquoi en prendre un ? 
Autant prendre un coupleur... mais bon c'est pas ce que je conseillerais, il y a bcp + d'intérêt a avoir un programme dans l'automate.

Ou alors j'ai pas tout compris ?

Si je comprends bien, la carte KNX permet de lire le réseau bus et de le programmer, mais elle doit avoir obligatoirement avoir sa propre carte réseau ?


Citation :Donc un port Ethernet MODBUS et un port pour le KNX ? Par exemple, le PFC200 possède 2 cartes réseaux, cela pourrai solutionner le problème ?

Non la carte KNX permet permet d'envoyer ou de recevoir des info sur le bus KNX.
Exemple : 
Chaudiere piloté en Modbus (Modbus sur PLC)
Eclairage piloté en DALI (Carte Dali sur PLC)

Tu vas faire un programme qui va gérer la chaudiere, mais il faut recevoir la dmd par exemple en % de chaud que chaque piece aura besoin, Ce % proviendra d'un bloc de régul KNX intégré a un BP par exemple 

Pour le DALI , c'est un détecteur de présence qui enverra la consigne en % d'eclairage voulu. 


Citation :Pour en revenir aux interrupteurs, je suis d'accords avec vous, mais cela reste essentiellement un problème de coûts.

Les interrupteurs conventionnelle remplissent très bien cette taches et en câblage sa coute pas forcement plus chère.
Oui mais avoir des retours d'etats sous forme de led, des sonde de T° intégré, eventuellement parfois un afficheurs dans certaines pièce intégré afin de donner des info est un réel plus.




Citation :J'ai eu les 1000m de RJ45 à 700euro. Ramené au au prix du mètre, le RJ soit moins chère que le BUS KNX.

Et pour réduire un peux les longueurs tirés, je peux créer des petites lignes à la manière  du BUS vu que j'ai 4 paires par câble ?
Je te déconseille d'utiliser du cable réseau a la place d'un eventuel bus KNX, 
Le Bus KNX c'est une section bien précise pour s'inserer dans un connecteur WAGO bien précis. Et je parle pas de toute les certif auxquelles le cable répond et qui non rien avoir avec les besoins du réseau.
KNX Partner Base / Avancé
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 2 visiteur(s)