Note de ce sujet :
  • Moyenne : 5 (1 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Projet communautaire Arduino ATMEGA KNX
#76
Je viens d'essayer avec le knx-demo-diy-tp, l'importation dans ETS se fait correctement, avec les paramètres définis, après je n'ai aucun des produits pour tester le chargement et l'utilisation final, mais il ne doit pas avoir franchement de problème.
Répondre
#77
Je ne suis pas sûr que nous parlions du même problème:
j'ai commencé avec les fichiers knx-demo-ip.ino et knx-demo-ip.knxprod.
J'ai installé knx-demo-ip.ino sur un ESP8266  et importé knx-demo-ip.knxprod dans ETS5 et à programmer le knx-demo-ip.ino au travers d'ETS5, et ca fonctionne parfaitement bien.

Par contre, je n'arrive pas à compiler le ficher knx-demo-ip.xml en knx-demo-ip.knxprog pour pouvoir programmer l'ESP8266 directement dans ETTS5.
As-tu réussi à compiler toi-même le .xml en .knxprod??? 

C'est à ce niveau que rame, et c'est une étape indispensable avant d'aller plus loin dans le développement de mes propres . ino et .knxprod.
Répondre
#78
(07/11/2021, 17:24:53)richardpub a écrit : Je ne suis pas sûr que nous parlions du même problème:
j'ai commencé avec les fichiers knx-demo-ip.ino et knx-demo-ip.knxprod.
J'ai installé knx-demo-ip.ino sur un ESP8266  et importé knx-demo-ip.knxprod dans ETS5 et à programmer le knx-demo-ip.ino au travers d'ETS5, et ca fonctionne parfaitement bien.

Par contre, je n'arrive pas à compiler le ficher knx-demo-ip.xml en knx-demo-ip.knxprog pour pouvoir programmer l'ESP8266 directement dans ETTS5.
As-tu réussi à compiler toi-même le .xml en .knxprod??? 

C'est à ce niveau que rame, et c'est une étape indispensable avant d'aller plus loin dans le développement de mes propres . ino et .knxprod.

J'ai quelques fois du mal à m'exprimer. Donc j'ai recommencé la procédure :
- J'ai ouvert le fichier knx-demo-ip.xml dans CreateKnxProd.
- J'ai modifier le nom du produit (je l'ai appelé "Thermomètre IP) pour voir si le fichier .knxprod soit bien ce fichier.
- Je l'ai exporté.
- Je l'ai ensuite importé dans ETS.
- Et je l'ai intégré à un projet.

Ensuite comme je l'ai dis, n'ayant pas le matériel physique en possession, je ne peux pas savoir s'il le téléchargement vers le participant fonctionne, mais l'ensemble des paramètres sont présent dans ETS.

Je te joins le fichier compilé .knxprod et tu pourras voir le nom du produit qui a changé. Attention supprime l'extension txt car le knxprod ne passe pas.


Pièces jointes
.txt   knx-demo-ip-2.knxprod.txt (Taille : 78,47 Ko / Téléchargements : 4)
Répondre
#79
Comment supprimes-tu l'extension .text. Quand je le fait l'import dans le catalogue d'ETS5 est refusé.
Quand tu dis:" J'ai ouvert le fichier knx-demo-ip.xml dans CreateKnxProd." tu parles de CreateKnxProd.exe ??
Quel méthode utilises-tu pour compiler ton fichier .xml en .knxprod ????

tu travaille avec le github de Thelsing CreateKnxProd ???
Répondre
#80
(08/11/2021, 00:17:16)richardpub a écrit : Comment supprimes-tu l'extension .text. Quand je le fait l'import dans le catalogue d'ETS5 est refusé.
Quand tu dis:" J'ai ouvert le fichier knx-demo-ip.xml dans CreateKnxProd." tu parles de CreateKnxProd.exe ??
Quel méthode utilises-tu pour compiler ton fichier .xml en .knxprod ????

tu travaille avec le github de Thelsing CreateKnxProd ???

Bonjour,

La je ne sais pas quoi te dire Huh , si tu es sous Windows pour renommer un fichier dans l’exploreur de dossier c'est la touche F2, ou click droit renommer, pour le dos c'est la commande "ren", sous Linux c'est "mv". C'est une des bases quand on fait de la programmation ....
Sinon oui j'utilise le CreateKnxProd que j'ai compilé du stack de Thelsing, j'ai pri son fichier xml d'exemple que j'ai chargé dans l'application compilé, je l'ai exporté, ce qui m'a créé un fichier knxProd que j'ai renommé pour que tu puisse le récupérer. Voilà je ne sais pas quoi tu dire de plus, à part utiliser Visual express 2017 pour utiliser la stack.

J'espère que tu vas pouvoir essayer le fichier demo car pour moi j'ai du mal à voir comment tu vas pour faire communiquer le bus KNX avec le module non KNX sans faire une interface de communication.
Répondre
#81
Si je pose cette question plutôt basique, c'est parce que après modification et suppression du .text, j'ai lors de l'importation dans le cataloque ETS5, l'erreur suivante:
[Image: 21110912430025602917660105.gif]

Je t'envoie mon mail en MP, si tu peux m'envoyer le fichier sans modification.

Cordialement
Répondre
#82
J'ai avancé avec une recherchecsur Google avec:

      The product has a different hash than the existing product.

Et la solution est :la réponse Q6

Je me suis rendu compte que je ne pouvais plus importer le fichier knx-demo-ip.knxprod des exemples de Thelsing

Je vais donc pouvoir avancer.
Répondre
#83
Je génère bien maintenant le fichier knx-demo-ip.knxprod.
Je l'importe bien dans ETS5, mais quand je l'insère comme participant, il m'affiche:

      "Le produit a un hachage différent par rapport au produit existant. "
Répondre
#84
(09/11/2021, 11:36:33)richardpub a écrit : Je génère bien maintenant le fichier knx-demo-ip.knxprod.
Je l'importe bien dans ETS5, mais quand je l'insère comme participant, il m'affiche:

      "Le produit a un hachage différent par rapport au produit existant. "

Bonsoir,
Tes problèmes de Hash doivent venir, et cela en général, d'un problème de signature du fournisseur.
Comme le fournisseur est ici l'"Association KNX", ils peuvent à leur guise changé de signature, cela leur est très facile car c'est eux qui développe ETS.
De là deux possibilité pour ton logiciel ETS :
- Soit tu as une version non à jour, je me rappelle que le passage de la version 5.5 à 5.6 à mis le "Virtual KNX" sans module ( à moins que ce soit le passage de la version 5.6 à 5.7, je ne sais plus).
- Ou soit tu as une version non officiel où la promesse du nombre de participants est illimités, mais le logiciel est sécurisé de manière à ce que le changement d'une partie du code empêche quand même certaines fonctionnalités d'être disponible, malgré le hacking du logiciel.
Je n'attends aucune réponse de ta part sur le logiciel, mais sache que sur la dernière version démo (5.7.5), l'importation se passe très bien.

_______________________________________________________________________
Petit rappel : Le fait de décompiler ou d'utiliser un logiciel décompilé est passible de poursuite judiciaire dans beaucoup de pays, même aux Etats-Unis d’Amérique donc nulle ne peut utilisé un code modifie à des fins personnels et encore moins à sa diffusion.
_______________________________________________________________________
Répondre
#85
Je suis en version 5.7.4 version( 1093) en version officielle

Mes problèmes de Hash viennent effectivement surement d'un problème de signature du fournisseur.
bizarrement après avoir dans les paramètres d'ETS5 à dépannage, en cochant vider le magasin produit de produit, l'importation se passe très bien, sans problème de hash,
que ce soit avec mon fichier knx-demo-ip.knxprod, ou avec le tien knx-demo-diy-tp.knxprod.

Donc, j'ai testé avec knx-demo-ip.xml et knx-demo-diy-ip.xml
et j'ai utilisé createknxprod pour créer knx-demo-ip.knxprod et knx-demo-diy-ip .knxprod.
Avant d'importer je dois parcourir les paramètres de réparation et vider le catalogue produit et le nettoyer dans ETS5
Ensuite je les importe bien dans ETS5, mais quand je les insère en tant que participant, pas de problème avec knx-demo-diy-ip.knxprod mais avec knx-demo-ip.knxprod comme participant s'affiche :
"Le produit a un hachage différent de celui du produit existant."

Lorsque j'utilise les knxprods déjà créés dans les exemples de Thelsing, ils fonctionnent parfaitement.

Il faut donc que je creuse la structure des fichier Xml au niveau du codage fabricant et produits

Saurais-tu me dire s'il y a un moyen de revenir en arrière sur un hash pour retrouver à partir du .knxprod la valeur du .xml

Peut-être avec le logiciel net'n Node5 ????

Merci pour ton soutie,, c'est bon de se sentir moins seul

J'attends des réponses du forum knx.de mais il n'est plus très actif sur le sujet.
Répondre
#86
(11/11/2021, 23:59:34)richardpub a écrit : Je suis en version 5.7.4 version( 1093) en version officielle

Mes problèmes de Hash viennent effectivement surement d'un problème de signature du fournisseur.
bizarrement après avoir dans les paramètres d'ETS5 à dépannage, en cochant vider le magasin produit de produit, l'importation se passe très bien, sans problème de hash,
que ce soit avec mon fichier knx-demo-ip.knxprod, ou avec le tien knx-demo-diy-tp.knxprod.

Donc, j'ai testé avec knx-demo-ip.xml et knx-demo-diy-ip.xml
et j'ai utilisé createknxprod pour créer knx-demo-ip.knxprod et knx-demo-diy-ip .knxprod.
Avant d'importer je dois parcourir les paramètres de réparation et vider le catalogue produit et le nettoyer dans ETS5
Ensuite je les importe bien dans ETS5, mais quand je les insère en tant que participant, pas de problème avec knx-demo-diy-ip.knxprod mais avec knx-demo-ip.knxprod comme participant s'affiche :
"Le produit a un hachage différent de celui du produit existant."

Lorsque j'utilise les knxprods déjà créés dans les exemples de Thelsing, ils fonctionnent parfaitement.

Il faut donc que je creuse la structure des fichier Xml au niveau du codage fabricant et produits

Saurais-tu me dire s'il y a un moyen de revenir en arrière sur un hash pour retrouver à partir du .knxprod la valeur du .xml

Peut-être avec le logiciel net'n Node5 ????

Merci pour ton soutie,, c'est bon de se sentir moins seul

J'attends des réponses du forum knx.de mais il n'est plus très actif sur le sujet.

Alors peux es-ce que tu as modifier le fichier "App.config" comme le demande Thelsing, entre autre le répertoire d'ETS ?
Répondre
#87
J'ai modifié le fichier knx-demo-ip.xml

Je dois toucher à App.config??? Je n'y ai rien fait pour l'instant

A quelle partie dois-je toucher??? celle en rouge??? 

<?xml version="1.0" encoding="utf-8"?>
<configuration>
    <configSections>
        <sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
            <section name="CreateKnxProd.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false"/>
        </sectionGroup>
    </configSections>
    <startup> 
        <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.7.2"/>
    </startup>

    <applicationSettings>
        <CreateKnxProd.Properties.Settings>
            <setting name="ETSPath" serializeAs="String">
                <value>C:\Program Files (x86)\ETS5\CV\5.6.241.33672</value>
            </setting>
            <setting name="Culture" serializeAs="String">
                <value>en</value>
            </setting>
            <setting name="UICulture" serializeAs="String">
                <value>en</value>
            </setting>
        </CreateKnxProd.Properties.Settings>
    </applicationSettings>
</configuration>

Du coup à tu touché au fichier .xml avant de le transformer en .knxprod???
Répondre
#88
Finalement je me rends compte que je l'ai effectivement mis à jour avec mon dernier fichier CV de KNX

Peux-tu me montrer les modification que tu as fait sur le fichier xml???
Répondre
#89
(12/11/2021, 13:36:18)richardpub a écrit : Finalement je me rends compte que je l'ai effectivement mis à jour avec mon dernier fichier CV de KNX

Peux-tu me montrer les modification que tu as fait sur le fichier xml???

Ce que tu as surligner doit être en effet modifier en fonction du répertoire ETS que tu as, et j'ai simplement modifier la valeur des cultures "de" -> "fr".

Voilà le code :

Code :
<?xml version="1.0" encoding="utf-8"?>
<configuration>
   <configSections>
       <sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
           <section name="CreateKnxProd.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false"/>
       </sectionGroup>
   </configSections>
   <startup>
       <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.7.2"/>
   </startup>

   <applicationSettings>
       <CreateKnxProd.Properties.Settings>
           <setting name="ETSPath" serializeAs="String">
               <value>C:\Program Files (x86)\ETS5\CV\5.6.241.33672</value>
           </setting>
           <setting name="Culture" serializeAs="String">
               <value>fr</value>
           </setting>
           <setting name="UICulture" serializeAs="String">
               <value>fr</value>
           </setting>
       </CreateKnxProd.Properties.Settings>
   </applicationSettings>
</configuration>
Répondre
#90
(12/11/2021, 13:31:40)richardpub a écrit : Du coup à tu touché au fichier .xml avant de le transformer en .knxprod???

Non je n'ai rien  touché.
J'ai regardé rapidement de code de Thesing et comme je le pensais c'est une valeur qui est calculé comme une partie de clé de cryptage sha256 ou autre.

Si te veux connaitre où trouver la valeur du Hash, il suffit de décompresser le fichier Knxprod comme une archive (comme un .zip).
De là tu as différent fichier et un répertoire, il faut ouvrir ce répertoire, puis le fichier xml commençant comme le nom du répertoire et au bout de la 6éme ligne tu auras le Hash. Mais je l'ai dit plus haut le hash sert d'identifiant unique du produit qui doit dépendre de la signature du fournisseur.
Répondre
#91
et dans le fichier .xml tu ne modifie pas le project 11???
avec mon numero de version d'ETS5 c'est avec project 14 que cela fonctionne

<
<?xml version="1.0" encoding="utf-8"?>
<KNX xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" CreatedBy="KNX MT" ToolVersion="5.6.407.26745" xmlns="http://knx.org/xml/project/11">
  <ManufacturerData>
    <Manufacturer RefId="M-00FA">
      <Catalog>
        <CatalogSection Id="M-00FA_CS-1" Name="Geräte" Number="1" DefaultLanguage="en-US">
          <CatalogItem Id="M-00FA_H-0124-0_HP-ABCE-79-0000_CI-IA4313-1" Name="Temperatursensor TP" Number="1" ProductRefId="M-00FA_H-0124-0_P-IA4313" Hardware2ProgramRefId="M-00FA_H-0124-0_HP-ABCE-79-0000" DefaultLanguage="en-US" />
        </CatalogSection>
      </Catalog>
      <ApplicationPrograms>
        <ApplicationProgram Id="M-00FA_A-ABCE-79-0000" ApplicationNumber="43982" ApplicationVersion="121" ProgramType="ApplicationProgram" MaskVersion="MV-07B0" Name="TK TEMP TP" LoadProcedureStyle="MergedProcedure" PeiType="0" DefaultLanguage="en-US" DynamicTableManagement="false" Linkable="false" MinEtsVersion="4.0">
          <Static>
            <Code>
              <RelativeSegment Id="M-00FA_A-ABCE-79-0000_RS-04-00000" Name="Parameters" Offset="0" Size="8" LoadStateMachine="4" />
            </Code>
            <ParameterTypes>
              <ParameterType Id="M-00FA_A-ABCE-79-0000_PT-startupTimeout" Name="startupTimeout">
                <TypeRestriction Base="Value" SizeInBit="8">
                  <Enumeration Text="0 s" Value="0" Id="M-00FA_A-ABCE-79-0000_PT-startupTimeout_EN-0" />
                  <Enumeration Text="1 s" Value="1" Id="M-00FA_A-ABCE-79-0000_PT-startupTimeout_EN-1" />
                  <Enumeration Text="2 s" Value="2" Id="M-00FA_A-ABCE-79-0000_PT-startupTimeout_EN-2" />
                  <Enumeration Text="3 s" Value="3" Id="M-00FA_A-ABCE-79-0000_PT-startupTimeout_EN-3" />
                  <Enumeration Text="4 s" Value="4" Id="M-00FA_A-ABCE-79-0000_PT-startupTimeout_EN-4" />
                  <Enumeration Text="5 s" Value="5" Id="M-00FA_A-ABCE-79-0000_PT-startupTimeout_EN-5" />
                  <Enumeration Text="6 s" Value="6" Id="M-00FA_A-ABCE-79-0000_PT-startupTimeout_EN-6" />
                </TypeRestriction>
              </ParameterType>
              <ParameterType Id="M-00FA_A-ABCE-79-0000_PT-TempChange" Name="TempChange">
                <TypeRestriction Base="Value" SizeInBit="8">
                  <Enumeration Text="Disabled" Value="0" Id="M-00FA_A-ABCE-79-0000_PT-TempChange_EN-0" />
                  <Enumeration Text="0.1 K" Value="1" Id="M-00FA_A-ABCE-79-0000_PT-TempChange_EN-1" />
                  <Enumeration Text="0.2 K" Value="2" Id="M-00FA_A-ABCE-79-0000_PT-TempChange_EN-2" />
                  <Enumeration Text="0.3 K" Value="3" Id="M-00FA_A-ABCE-79-0000_PT-TempChange_EN-3" />
                </TypeRestriction>
              </ParameterType>
              <ParameterType Id="M-00FA_A-ABCE-79-0000_PT-TempCycle" Name="TempCycle">
                <TypeRestriction Base="Value" SizeInBit="8">
                  <Enumeration Text="Disabled" Value="0" Id="M-00FA_A-ABCE-79-0000_PT-TempCycle_EN-0" />
                  <Enumeration Text="1 min" Value="1" Id="M-00FA_A-ABCE-79-0000_PT-TempCycle_EN-1" />
                  <Enumeration Text="2 min" Value="2" Id="M-00FA_A-ABCE-79-0000_PT-TempCycle_EN-2" />
                  <Enumeration Text="3 min" Value="3" Id="M-00FA_A-ABCE-79-0000_PT-TempCycle_EN-3" />
                </TypeRestriction>
              </ParameterType>
              <ParameterType Id="M-00FA_A-ABCE-79-0000_PT-TempAbgleich" Name="TempAbgleich">
                <TypeNumber SizeInBit="32" Type="signedInt" minInclusive="-50" maxInclusive="50" />
              </ParameterType>
              <ParameterType Id="M-00FA_A-ABCE-79-0000_PT-TempSendMinMax" Name="TempSendMinMax">
                <TypeRestriction Base="Value" SizeInBit="8">
                  <Enumeration Text="Disabled" Value="0" Id="M-00FA_A-ABCE-79-0000_PT-TempSendMinMax_EN-0" />
                  <Enumeration Text="Send Enable" Value="1" Id="M-00FA_A-ABCE-79-0000_PT-TempSendMinMax_EN-1" />
                </TypeRestriction>
              </ParameterType>
            </ParameterTypes>
            <Parameters>
              <Parameter Id="M-00FA_A-ABCE-79-0000_P-1" Name="startupTimeout" ParameterType="M-00FA_A-ABCE-79-0000_PT-startupTimeout" Text="Startup delaytime" Value="0">
                <Memory CodeSegment="M-00FA_A-ABCE-79-0000_RS-04-00000" Offset="0" BitOffset="0" />
              </Parameter>
              <Parameter Id="M-00FA_A-ABCE-79-0000_P-2" Name="Aender Senden" ParameterType="M-00FA_A-ABCE-79-0000_PT-TempChange" Text="Send actual value after change of" Value="0">
                <Memory CodeSegment="M-00FA_A-ABCE-79-0000_RS-04-00000" Offset="1" BitOffset="0" />
              </Parameter>
              <Parameter Id="M-00FA_A-ABCE-79-0000_P-3" Name="ZyklSenden" ParameterType="M-00FA_A-ABCE-79-0000_PT-TempCycle" Text="Send  actual temperature cyclically" Value="0">
                <Memory CodeSegment="M-00FA_A-ABCE-79-0000_RS-04-00000" Offset="2" BitOffset="0" />
              </Parameter>
              <Parameter Id="M-00FA_A-ABCE-79-0000_P-4" Name="MinMaxSenden" ParameterType="M-00FA_A-ABCE-79-0000_PT-TempSendMinMax" Text="Send min/max value" Value="0">
                <Memory CodeSegment="M-00FA_A-ABCE-79-0000_RS-04-00000" Offset="3" BitOffset="0" />
              </Parameter>
              <Parameter Id="M-00FA_A-ABCE-79-0000_P-5" Name="Abgleich" ParameterType="M-00FA_A-ABCE-79-0000_PT-TempAbgleich" Text="Internal sensor correction value (value * 0.1 K)" Value="0">
                <Memory CodeSegment="M-00FA_A-ABCE-79-0000_RS-04-00000" Offset="4" BitOffset="0" />
              </Parameter>
            </Parameters>
            <ParameterRefs>
              <ParameterRef Id="M-00FA_A-ABCE-79-0000_P-1_R-1" RefId="M-00FA_A-ABCE-79-0000_P-1" />
              <ParameterRef Id="M-00FA_A-ABCE-79-0000_P-2_R-2" RefId="M-00FA_A-ABCE-79-0000_P-2" />
              <ParameterRef Id="M-00FA_A-ABCE-79-0000_P-3_R-3" RefId="M-00FA_A-ABCE-79-0000_P-3" />
              <ParameterRef Id="M-00FA_A-ABCE-79-0000_P-4_R-4" RefId="M-00FA_A-ABCE-79-0000_P-4" />
              <ParameterRef Id="M-00FA_A-ABCE-79-0000_P-5_R-5" RefId="M-00FA_A-ABCE-79-0000_P-5" />
            </ParameterRefs>
            <ComObjectTable>
              <ComObject Id="M-00FA_A-ABCE-79-0000_O-1" Name="Current temperature value" Text="Current temperature value" Number="1" FunctionText="Transmit temperature value" ObjectSize="2 Bytes" ReadFlag="Enabled" WriteFlag="Disabled" CommunicationFlag="Enabled" TransmitFlag="Enabled" UpdateFlag="Disabled" ReadOnInitFlag="Disabled" DatapointType="" />
              <ComObject Id="M-00FA_A-ABCE-79-0000_O-2" Name="Max memory value" Text="Max memory value" Number="2" FunctionText="Read memory" ObjectSize="2 Bytes" ReadFlag="Enabled" WriteFlag="Disabled" CommunicationFlag="Enabled" TransmitFlag="Enabled" UpdateFlag="Disabled" ReadOnInitFlag="Disabled" DatapointType="" />
              <ComObject Id="M-00FA_A-ABCE-79-0000_O-3" Name="Min memory value" Text="Min memory value" Number="3" FunctionText="Read memory" ObjectSize="2 Bytes" ReadFlag="Enabled" WriteFlag="Disabled" CommunicationFlag="Enabled" TransmitFlag="Enabled" UpdateFlag="Disabled" ReadOnInitFlag="Disabled" DatapointType="" />
              <ComObject Id="M-00FA_A-ABCE-79-0000_O-4" Name="Min/max memory reseet" Text="Min/max memory reseet" Number="4" FunctionText="Reset memory" ObjectSize="1 Bit" ReadFlag="Disabled" WriteFlag="Enabled" CommunicationFlag="Enabled" TransmitFlag="Disabled" UpdateFlag="Disabled" ReadOnInitFlag="Disabled" DatapointType="" />
            </ComObjectTable>
            <ComObjectRefs>
              <ComObjectRef Id="M-00FA_A-ABCE-79-0000_O-1_R-1" RefId="M-00FA_A-ABCE-79-0000_O-1" />
              <ComObjectRef Id="M-00FA_A-ABCE-79-0000_O-2_R-2" RefId="M-00FA_A-ABCE-79-0000_O-2" />
              <ComObjectRef Id="M-00FA_A-ABCE-79-0000_O-3_R-3" RefId="M-00FA_A-ABCE-79-0000_O-3" />
              <ComObjectRef Id="M-00FA_A-ABCE-79-0000_O-4_R-4" RefId="M-00FA_A-ABCE-79-0000_O-4" />
            </ComObjectRefs>
            <AddressTable MaxEntries="65000" />
            <AssociationTable MaxEntries="65000" />
            <LoadProcedures>
              <LoadProcedure MergeId="2">
                <LdCtrlRelSegment AppliesTo="full" LsmIdx="4" Size="8" Mode="0" Fill="0" />
              </LoadProcedure>
              <LoadProcedure MergeId="4">
                <LdCtrlWriteRelMem ObjIdx="4" Offset="0" Size="8" Verify="true" />
              </LoadProcedure>
            </LoadProcedures>
            <Options />
          </Static>
          <Dynamic>
            <ChannelIndependentBlock>
              <ParameterBlock Id="M-00FA_A-ABCE-79-0000_PB-1" Name="ParameterPage" Text="Allgemeine Parameter">
                <ParameterRefRef RefId="M-00FA_A-ABCE-79-0000_P-1_R-1" />
                <ParameterRefRef RefId="M-00FA_A-ABCE-79-0000_P-2_R-2" />
                <ParameterRefRef RefId="M-00FA_A-ABCE-79-0000_P-3_R-3" />
                <ParameterRefRef RefId="M-00FA_A-ABCE-79-0000_P-4_R-4" />
                <ParameterRefRef RefId="M-00FA_A-ABCE-79-0000_P-5_R-5" />
                <ComObjectRefRef RefId="M-00FA_A-ABCE-79-0000_O-1_R-1" />
                <ComObjectRefRef RefId="M-00FA_A-ABCE-79-0000_O-2_R-2" />
                <ComObjectRefRef RefId="M-00FA_A-ABCE-79-0000_O-3_R-3" />
                <ComObjectRefRef RefId="M-00FA_A-ABCE-79-0000_O-4_R-4" />
              </ParameterBlock>
            </ChannelIndependentBlock>
          </Dynamic>
        </ApplicationProgram>
      </ApplicationPrograms>
      <Hardware>
        <Hardware Id="M-00FA_H-0124-0" Name="SAMD Random" SerialNumber="0124" VersionNumber="0" BusCurrent="10" HasIndividualAddress="true" HasApplicationProgram="true">
          <Products>
            <Product Id="M-00FA_H-0124-0_P-IA4313" Text="Temperatursensor TP" OrderNumber="IA4313" IsRailMounted="false" DefaultLanguage="en-US" />
          </Products>
          <Hardware2Programs>
            <Hardware2Program Id="M-00FA_H-0124-0_HP-ABCE-79-0000" MediumTypes="MT-0">
              <ApplicationProgramRef RefId="M-00FA_A-ABCE-79-0000" />
            </Hardware2Program>
          </Hardware2Programs>
        </Hardware>
      </Hardware>
    </Manufacturer>
  </ManufacturerData>
</KNX>

uniquement les partie en violet

c'est à dire la version d'ETS5 pour moi en 5.6.241.33672 et project 11 en project 14
Répondre
#92
Sans toucher au fichier knx-demo-ip.xml j'ai ceci comme erreur:

[Image: 21111205510625602917665788.gif]
Répondre
#93
dans le fichier de création de createknxprod le tool version n'est pas celle que j'utilise
Serais-ce la raison de mes soucis:

private IDialogService _dialogService;

        private const string _toolName = "KNX MT";
        private const string _toolVersion = "5.1.255.16695";

        private string _openFile = null;
        private KNX _model = null;
Répondre
#94
(12/11/2021, 17:29:09)richardpub a écrit : <KNX xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" CreatedBy="KNX MT" ToolVersion="5.6.407.26745" xmlns="http://knx.org/xml/project/11">
uniquement les partie en violet

c'est à dire la version d'ETS5 pour moi en 5.6.241.33672 et project 11 en project 14

Autant pour moi, comme je l'ai est tous modifié, cela m'est sortie de l'esprit. 

Citation :Dans le fichier de création de createknxprod le tool version n'est pas celle que j'utilise
Serais-ce la raison de mes soucis:

private IDialogService _dialogService;

        private const string _toolName = "KNX MT";
        private const string _toolVersion = "5.1.255.16695";

        private string _openFile = null;
        private KNX _model = null;

Là c'est la version de KNX Manufactor Tool qui est censé être utilisé pour créer le device. Logiciel distribué aux fabricants.

Si tu veux gratter dans le code, il faut plutôt aller vers la fonction "private void Export(object param)" de mainWindowModel où tu auras la création des fichiers xml et knxprod.
Mais pour l'instant de mon côté je n'ai pas de temps à faire de la rétroEngenering.
Répondre
#95
Je vais me mettre un peu en pause car à force de partir dans tous les sens je suis un peu paumé.

Je suis reparti de zéro car à force tout se mélange...

En tout cas encore merci
Répondre
#96
Après avoir passé pas mal d'heures sur le forum KNX allemand et dans les différents github j'ai enfin fini par comprendre comment fonctionnait la création d'un fichier knxprod à partir d'un fichier XML en passant par MultiplyChannels.exe?
Il faut passer par new, et non par create et ensuite renseigner les différents paramètres.
Je n'ai pas encore compris quels sont les paramètres essentiels à renseigner en fonction du fichier XML de départ mais j'ai enfin réussi à créer mon premier fichier knxprod directement fonctionnel dans ETS5.
Je vais pouvoir revenir sur le fichier démo de Thelsing.
Dommage que l'on ne trouve pas quelque part un petit tutoriel qui éviterait un grand nombre de questions sur le forum mais j'en demande peut-être beaucoup. (j'en ferait un dès que j'aurais résolu tout mes problèmes).
Il faut aussi que chacun sache être autonome.

Cordialement.
Répondre
#97
Je croyait avoir trouvé la solution, mais finalement j'ai encore pas mal pataugé avant de trouver la solution qui mui me convient:

Je voulais réussir à utiliser Createknxprod .

Du coup après mise à jour vers la  dernière version d'ETS5 qui est pour moi la "5.7.6".

J'ai enfin réussi à générer avec Createknxprod un fichier .knxprod fonctionnel.

Dans la partie .xml du fichier exemple,  avec cette version d'ETS5 j'ai mis "project 20". 
Dans la partie graphique de  logiciel Createknxprod,  j'ai renseigné des numero de série et différents champs que j'avais laissé à 0.
Et j'ai enfin obtenu un fichier .knxprod fonctionnel dans ETS5.
Je vais enfin pouvoir faire avancer mon projet météo et celui d'analyse du taux de sel de la piscine.

Cordialement
Répondre
#98
Bonsoir,

Petit passage rapide, pour vous transmettre une petite vue du proto que je viens de finir. Cela rentre au chausse-pied, mais cela rentre. Maintenant, je dois produire une carte d’essais pour le STKNX, car certaines données technique de la puce me laisse perplexe.

A bientôt.


Pièces jointes Miniature(s)
   
Répondre
#99
(09/12/2021, 18:06:56)M2D a écrit : Bonsoir,

Petit passage rapide, pour vous transmettre une petite vue du proto que je viens de finir. Cela rentre au chausse-pied, mais cela rentre. Maintenant, je dois produire une carte d’essais pour le STKNX, car certaines données technique de la puce me laisse perplexe.

A bientôt.

Bonsoir,
Interessant projet, j'aurais 2 questions...
Tout d'abord, quel microcontrôleur as tu utiliser ?
Enfin, plus important, quel stack logiciel pense tu utiliser ?

De mon côté je continu d'avancer sur ma carte KnxBoardV1 (stm32/stknx) j'ai une stack qui commence de fonctionner, je ne gere pas encore la colision, mais j'en suis a l'implementation de la couche transport pour gérer la programmation ETS.
La couche datalink avec le stknx est bien complexe elle.. pour suporter les timings du protocole, j'ai du tout coder d'une façon assez particulière en utilisant de façon intensive les timer et les irq, d'ou ma curiosité sur ton projet...
En parallèle, j'ai fini le routage de la KnxBoardV2, basé Sur le NCN5130 (bien plus simple a gérer niveau logiciel, c'est comme un tpuart). Avec un routage 4 couches, elle fait seulement 25x32mm environ, ce qui me permettrait un usage dans plein de projet.
Malheureusement, ma première cotation sur seedstudio est de 450€ pour 5 cartes (pour la v1, j'avais eu une super promo pcba gratuit, ce qui m'avait coûter 100€ les 5...) je sais pas si c'est les prix ou lier a la conjecture actuel, du coup, j'ai mis en suspend la v2 et essai de finir la v1 (j'ai encore 4 carte utilisable, j'en ai grillé une par erreur).

Bref bonne chance pour ton projet
Répondre
De mon côté, j'ai enfin réussi à comprendre comment générer le fichier knx-demo.knxprod à partir du fichier knx-demo.xml avec l'utilitaire createknxprod.exe.
Il me manquait de renseigner les bonnes caractéristiques du fabriquant et du participant, pour enfin générer des fichiers .knxprod totalement fonctionnels dans ETS5.
Malheureusement maintenant j'arrive à flasher ESP8266 avec le fichier knx-demo.ino avec IDE Arduino, mais je n'arrive plus à activer le bouton pour télécharger totalement le participant avec ETS5. J'avais réussi à le faire avant de ramer avec createknxprod, mais maintenant je n'arrive plus à le faire.
Je n'ai pas trouvé d'aide sur le forum knx allemand, mais je pense qu'il faut que je reparte du GitHub d'origine, j'ai peut être loupé quelque chose.
Je me demande s'il n'y a pas une méthode pour remettre le flash de l'ESP8266 à zéro ( je me demande si je n'avais fait quelque chose de ce genre pour être fonctionnel).
Et tant que je n'aurais pas réussi à rendre le knx-demo fonctionnel, je je pourrais pas passer à la création des codes adapté à mes projets actuels.
J'ai parfois l'impression de courir après une chimère.
Un peu d'aide serait bien venue.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)