Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Problème de communication IPR/S3.1.1 - Wago
#1
Salut tout le monde !

Je vous remercie d'avance pour votre temps.

Je suis apprenti automaticien en dernière année et on m'a demandé de mettre en service une installation, je vous demande de l'aide parce que je suis celui qui connaît le mieux le KNX dans l'entreprise... Voici la description de mon installation:

Description:

Tous les participants du projets viennent de ABB, le logiciel que j'utilise pour programmer tout ça et ETS5. En gros j'ai 6 bâtiments, reliés par des router IP (ci-dessous)  et un automate wago programmé avec le KNX pour gérer l'éclairage extérieur de ces bâtiments.


Topologie (en simplifié):
Bâtiment 1:
  1. Alimentation
  2. Router IP (IPR/S3.1.1) (192.168.50.01)
  3. 8xDO SA/S8.16.5.1
  4. Carte Wago TP1-Klemme
Bâtiment 2:
  1. Alimentation
  2. Router IP (IPR/S2.1) (192.168.50.02)
  3. 2xDO (SA/S2.16.5.1)
Bâtiment 3:
  1. Alimentation
  2. Router IP (IPR/S3.1.1)(172.24.173.XX)
  3. 4xDO SA/S4.16.5.1

Mon problème est le suivant:
Je n'ai aucun problème entre les bâtiments 1 et 2, l'automate fonctionne et le KNX réceptionne les signaux correctement. Les sorties s'activent normalement entre ces bâtiments.
En revanche, le bâtiment 3 m'embête un peu... Je peux pinger le router n°3, commander les sorties à distances et lire les changements d'état sur la ligne mais les sorties ne s'activent jamais sur ordre du Wago. J'ai déjà essayer énormément de choses mais je ne vois plus ce que je peux faire, j'ai changé les adresses, changé les participants avec des neufs et rechargé tous les programmes dans tous les participants.

Au début je me suis dit que c'était normal car les 2 premiers bâtiments sont connectés sur le réseau "technique" (192.168.50.XXX) et le bâtiment 3 sur le réseau "bureautique" (172.24.173.XXX), donc que ça ne pouvait pas communiquer. Mais, les 2 réseaux sont enfaite connectés, j'arrive même à me connecter sur le router ip du bâtiment 1 ou 2 et charger des participants du bâtiment 3 à travers.

Quelqu'un saurait me dire pourquoi c'est le seul endroit où les signaux wago n'arrivent pas  ?

Merci beaucoup.
Répondre
#2
Bonjour et bienvenu.

Qu'ETS accède a ton réseau du batiment 3 depuis le 1 par exemple est une chose, mais je ne suis pas sur que cela reflete la réalité.

Je te conseille de te documenter sur les router KNX.
L'accès ne se fait pas via l'adresse IP des routeur, un routeur ne sait pas qu'un autre routeur est là sur le réseau !!
Ca se fait en Multicast sur l'adresse 224.0.23.12 via le port 3671.
Il faut que tu t'assure que la config réseau laisse passer ca entre tes batiments.


Sinon plus simple :
Si vous avez des switchs manageable, il suffit de créer un VLAN rien que pour le KNX.


Sinon avec les routeurs il faut maitriser aussi les tables de filtrage.
Par defaut on autorise les message pour une meme ligne.
Si tu dois changer de ligne/zone il faut paramétrer ton routeur pour qu'il ne filtre pas les messages.
Pour finir il faut a chaque fois qu'une GA est modifié bien penser a mettre a jour les routeur en leur transferant l'application pour mettre a jour cette table (suffit de surveiller les flag qui indique qu'un participant a été modifié.)
KNX Partner Base / Avancé
Répondre
#3
Filou aurais-tu un tuto sur les switch manageable, car un switch Cisco où je dois manager le multicast et la je rame vraiment en termes de méthode.
Il y a bien des kilomètres d'aide associé au switch, mais je ne sais trop par où commencer. Et je voudrais bien ca continue de fonctionner sans tout casser.
Répondre
#4
Alors la non désolé je touche un peu a du switch manageable chez moi mais sur du Mikrotik.

Cisco trop cher et trop compliqué pour moi, je laisse ca a ceux dont c'est le métier.

Tu n'as pas la posssibilité de créer un vlan qui serrait commun a tous tes batiments ? Car ca serra plus simple a faire et ladessus tu devrais trouver des tuto plus facilement ?
KNX Partner Base / Avancé
Répondre
#5
OK merci pour le conseil
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)