Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Configuration anémomètre avec participant KNX 0-10V
#1
Bonjour,

J'ai un petit soucis de configuration d'un anémomètre avec un capteur ABB 6109-28.

Comme vous pouvez le voir sur le fichier joint, le capteur à une entrée 0-10 V en lecture. 
Donc je me suis dit que je pouvais brancher un anémomètre de type tension variable 0-10 V.
La seule documentation que j'ai pour l'anémomètre est : fichier doc

J'ai essayé d'alimenter le l'anémomètre avec une alimentation dédiée, mais aussi directement avec le 30V du bus sans résultats probants. 
J'obtiens soit une valeur fixe, qui n'est pas influencée par la vitesse de rotation, soit une valeur qui augmente jusqu'à la valeur max... 

Mon problème, je pense, se situe au niveau de la masse. L'anémomètre a une sortie signal avec un seul fil, mais il faut deux fils pour le capteur...

Si quelqu'un aurait une idée de branchement, je suis preneur.

Merci


Pièces jointes Miniature(s)
   
Répondre
#2
Salut

1) Deja ne jamais utiliser l'alim KNX pour autre chose que du KNX. En plus KNX = 30V ton anémometre 24V maxi !!!
2) Ton anémometre c'est bien un modele 0-10V que tu as commandé car vu la doc je supose que c'est a la commande que tu choisi le type de sortie que tu veux.
Si c'est bien le cas alimente ton anémometre en 24V, puis prend un voltmetre pour vérifier entre le 0V et la sortie la tension qu'il sort.

3) Ensuite tu cables sur ton ABB , Sortie anémotre sur E1, et 0V de ton capteur sur la masse de ton ABB (les 2 bornes au 2 extremités)
KNX Partner Base / Avancé
Répondre
#3
Salut,

Merci pour le retour.
En effet, je me suis rendu compte que le KNX n'apprécie pas trop quand autre chose est connecté sur la boucle...

J'ai bien un anémomètre 0-10V, testé avec voltmètre et alim indépendante.
Mon problème se situe au niveau du 0V de l'anémomètre. Je ne sais pas quel fil utiliser.
La masse de l'alim ?
Répondre
#4
Oui c'est ca
KNX Partner Base / Avancé
Répondre
#5
J'ai bien un retour si je branche la masse de l'alim sur le 0V j'ai bien des valeurs qui sont lues.

Mais elles varient entre ~19000 et ~30000 pour du vent allant de 0 à 60 km/h (l'élément est configuré en valeur sur 2 octets 0 ... 65.535

Je pensais avoir 0 pour 0 km/h et 65.535 pour > 50 km/h...
Répondre
#6
Quand tu as un une station meteo ou un anémometre KNX pur, le participant en question va mesurer la vitesse du vent via un capteur interne , en gros il va convertir une grandeur electrique en une vitesse qui serra en Km/h qui serra facilement interpretable

Là toi tu as choisi un anémometre lambda qui sort un signal 0-10V, il faut donc que tu fasses une mise a l'echelle, il faut pour cela prendre la doc et savoir quel valeur de tension il va renvoyer pour tel ou tel vitesse de vent en esperant que ce soit linéaire.

Après tu peux essayer de changer le DPT mais si la conversion n'est pas au standard KNX ta valeur ne voudra rien dire.

Soit tu fais ca avec un participant capable de faire des opérations arithmétique soit avec un superviseur.
KNX Partner Base / Avancé
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)