Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Flag S
#1
Bonjour,

Je commence à faire mumuse avec ma linknxwebbox, et je rencontre des petits problèmes, qui sont, je pense, liés à ma config ETS.

Déjà, j'aimerais savoir ce qu'implique le flag S pour une sortie d'actuateur ? Je comprend bien que pour un bouton qui est dans plusieurs GA, seule celle ayant le flag S sera émise lors de l'appui (il ne peut y en avoir qu'une). Mais je ne comprend pas ce que ça fait pour une sortie...

Merci d'avance pour vos lumières.
Répondre
#2
Bonjour

Peut être pour émettre le retour d'état ?

Philippe
Intégrateur en domotique. Certifié KNX Partners

http://www.domosol.fr
Répondre
#3
Ben, il existe un objet spécial, pour le retour d'état. Lui, je comprend bien qu'il ait le flag S... Mais la sortie, je ne vois pas.
Répondre
#4
Oui, moi aussi, c'est quoi le flag S?, ou trouves-tu ce flag?, je ne vois que CRWUT.
Intégrateur Domotique et multimédias - KNX Partner n°26920 ADVANCED
http://www.ihabitation.com
Partenaire Lifedomus et SONOS
Répondre
#5
Je n'ai pas ETS sous les yeux, mais on voit ce flag dans les GA.

Ce flag indique sur quelle GA va émettre un objet, car un objet peut être lié à plusieurs GA, mais ne peut émettre que sur une seule. Pour les autres, il ne fait qu'écouter, et maintenir son état interne cohérent (pour un bouton toggle, par exemple).
Répondre
#6
Bonjour, ca va rejoindre ce que fma38 dit et en meme temps le corriger: un objet de communication peut posséder plusieurs actifs avec le Flag S. Mais uniquement pour le coté actionneurs.
Un interrupteur ne peut commander deux points différents, ou meme us, mais un point d'éclairage (ou chauffage ou autre) peut recevoir plusieurs commandes. Les va et vient en traditionnel par exemple, le all off, etc.

Donc, le Flag S indique qu'il va réagir à l'action et pas uniquement se mettre à jour, ce qui serait le cas pour les objets ne possédant pas le Flag S.
En espérant avoir répondu à la question,
Olivier
Intégrateur en solutions domotiques résidentielles, tertiaires et industrielles
Répondre
#7
(11/06/2012, 07:44:46)olivier.p a écrit : Bonjour, ca va rejoindre ce que fma38 dit et en meme temps le corriger: un objet de communication peut posséder plusieurs actifs avec le Flag S. Mais uniquement pour le coté actionneurs.
Un interrupteur ne peut commander deux points différents, ou meme us, mais un point d'éclairage (ou chauffage ou autre) peut recevoir plusieurs commandes. Les va et vient en traditionnel par exemple, le all off, etc.

Donc, le Flag S indique qu'il va réagir à l'action et pas uniquement se mettre à jour, ce qui serait le cas pour les objets ne possédant pas le Flag S.
En espérant avoir répondu à la question,
Olivier

Bonjour, 

Je déterre le sujet car j'ai rencontré un comportement singulier suite à l'utilisation du flag S.
Peut-être pourrez-vous m'éclairer si j'ai fais fausse route.

Prenons le cas simplifié de 2 boutons poussoirs (appelons les BPREZ et BPETAGE) et de 3 sorties TOR (A pour les lampes du rez, B pour celles de l'étage et C pour les led des marches de l'escalier).

BPREZ actionne A et C
BPETAGE actionne B et C

On crée une GA "GA1" avec l'objet de commutation de BPREZ ainsi que les objets de A et de C
On crée une GA "GA2" avec l'objet de commutation de BPETAGE ainsi que les objets de B et de C

Disons que ce sont les 2 seules GA utilisant ces boutons et ces actionneurs de sortie.

Par défaut, "GA1" aura ses 3 objets avec les flags S actifs puisque A et C sont utilités pour la première fois.
Par défaut, "GA2" aura quand à elle ses objets "BPETAGE" et "B" avec le flag S actif puisque utilisés pour la première fois.
Par contre, la sortie TOR C n'auras pas de flag S car l'objet est déjà avec flag S dans "GA1".

Comme il est impossible de supprimer le flag S d'un objet (l'objet de sortie doit avoir exactement 1 et 1 seul flag S actif, ni 0, ni 2), lorsque l'on actionnera BPETAGE, le flag S de B dira à C de se mettre à jour, et C appelera GA1 à cause de son flag S dans GA1 (flag d envoi), ce qui modifiera l'état de A via la GA1. Les 3 lampes s'allumeront...

Dans un cas comme celui-ci, la seule solution que j'ai trouvé est de créer une première GA appelée GAbidonX, et d'y mettre mon objet X de sortie avec flag S actif, cette GA n'étant jamais appelée et l'objet étant seul dans la GA.

Ainsi, dans mes GA1 et GA2, aucun flag S actif sur les objets des actionneurs de sortie. Et GA1 actionnera bien le rez et l'escalier uniquement, idem pour GA2 qui actionnera bien l'étage et l'escalier uniquement.

Est-ce correct ? Votre avis sur le sujet ? 

Merci pour vos retours.
Répondre
#8
Bonjour,
est-ce un cas réel, ou de la pure théorie ? Le flag S n'est pas actif normalement sur des sorties, de mémoire. Car une sortie n'envoie pas d'informations sur le bus . l'interrupteur oui, et le statut de la sortie, oui.
Ton exemple laisse penser que tu as mis les statuts des commandes, en plus des commandes dans les adresses de groupe

Bonne soirée,
Olivier
Intégrateur en solutions domotiques résidentielles, tertiaires et industrielles
Répondre
#9
(31/01/2018, 21:55:43)olivier.p a écrit : Bonjour,
est-ce un cas réel, ou de la pure théorie ? Le flag S n'est pas actif normalement sur des sorties, de mémoire. Car une sortie n'envoie pas d'informations sur le bus . l'interrupteur oui, et le statut de la sortie, oui.
Ton exemple laisse penser que tu as mis les statuts des commandes, en plus des commandes dans les adresses de groupe

Bonne soirée,
Olivier

Salut Olivier, 

Cas réel, en effet, je parle bien du statut des commandes, intégrés aux GA avec les sorties.
Quelle serait la bonne pratique dans ce cas de figure ? Dédier des GA avec les status des commandes ? Autre ?
Répondre
#10
Oui, dédié c'est préférable pour éviter ce genre de bug :-)
Intégrateur en solutions domotiques résidentielles, tertiaires et industrielles
Répondre
#11
(04/02/2018, 13:13:34)olivier.p a écrit : Oui, dédié c'est préférable pour éviter ce genre de bug :-)

 Entendu, mais dans ce cas ne suffirait-il pas de créer une seule GA dédiée avec tous les retours d’état  et tous les interrupteurs dedans ? Quelles limitation y aurait-il à cela ? 

Cela fonctionnerait non ?
Répondre
#12
Si tu veux utiliser les états pour une visualisation, tu dois les mettre dans des groupes séparés. Si tu n'en a pas besoin, tu ne dois pas non plus forcément les mettre dans un groupe. Chaque objet de chaque composant ne doit pas systematiquement se retrouver dans un groupe Wink
Intégrateur en solutions domotiques résidentielles, tertiaires et industrielles
Répondre
#13
Salut Olivier,

Etant donné que je dois configurer mon Domovea, c'est bon à savoir, merci d'avoir pris le temps de me répondre.
Répondre
#14
Bonjour,

Je reprends une installation en TX100 et je pense que le Flag S est mon problème, je m'explique:

J'ai 2 interrupteurs HAGER 302 (sans voyant) BP1 et BP2 en télérupteur ON/OFF et 1 interrupteur BP3 HAGER 312 (avec voyant) en OFF uniquement.
Mes sorties sont 2 lampes L1 et L2  sur TXA207B HAGER

Dans 1 er temps j'ai programmé BP1 pour L1 et BP2 pour L2:
0/0 Marche Arrêt
0/0/1 Bouton Poussoir 1 ON-OFF  S CR-TU
........ Sortie 1 ON-OFF                 S CRW-U
0/0/2 Bouton Poussoir 2 ON-OFF  S CR-TU
........ Sortie 2 ON-OFF                 S CRW-U
0/1 Etats Marche Arrêt
0/1/1 Bouton Poussoir 1 Indication Etat  S CRW-U
........ Sortie 1  Indication Etat                S CR-TU
0/1/2 Bouton Poussoir 2 Indication Etat  S CRW-U
........ Sortie 2  Indication Etat                S CR-TU

Jusque là, tout marche bien
Comme vous en doutez je veux faire sur BP3:
- une extinction générale.
- La Led du BP 3 s'allume si BP1 ou BP2 est allumée.

Je pensais compléter comme ceci (première version):
0/0 Marche Arrêt
0/0/3 Bouton Poussoir 3 ON-OFF S  CR-TU
........ Sortie 1 ON-OFF                -  CRW-U
........ Sortie 2 ON-OFF                -  CRW-U
0/1 Etats Marche Arrêt
0/1/3 Sortie 1  Indication Etat                 -  CR-TU
........ Sortie 2  Indication Etat                 -  CR-TU
........ Voyant 3 - Signalisation                 S CRW-U
    Il n'y a pas de Bouton Poussoir 3 Indication Etat  S CRW-U car je suis en OFF uniquement

2eme version:
0/0 Marche Arrêt
0/0/3 Bouton Poussoir 3 ON-OFF S  CR-TU
........ Sortie 1 ON-OFF                -  CRW-U
........ Sortie 2 ON-OFF                -  CRW-U
0/1 Etats Marche Arrêt
0/1/1 Bouton Poussoir 1 Indication Etat  S CRW-U
........ Sortie 1  Indication Etat               S CR-TU
........ Voyant 3 - Signalisation               - CRW-U
0/1/2 Bouton Poussoir 2 Indication Etat  S CRW-U
........ Sortie 2  Indication Etat                S CR-TU
........ Voyant 3 - Signalisation                -  CRW-U

Mais cela m'amène à une autre réflexion.
Si L1 et L2 sont allumées, le voyant BP3 le sera aussi.
Puis si j'éteint L1, le voyant BP3 s'éteindra, non ?
Alors que BP3 devrait rester allumé car L1 l'est encore.

En lisant "LES FLAGS KNX/EIB DANS ETS"  (http://virgyl.f.free.fr/domogik/Document...ag_ETS.pdf), je constate que les Flags par défaut de HAGER sont presque à l'opposé des recommandations.

Du coup je suis un peu perdu d'autant plus que sous TX100 cela marchait

Pouvez-vous m'éclairez.

Merci.
Répondre
#15
Ton système fonctionne correctement .... en tous cas le système répond exactement à ta programmation !!!

Le problème vient d'une mauvaise conception au niveau de ta led du BP3 :
sur le BP 3 tu mets une lecture des GA 0/1/2 et 0/1/1 pour la signalisation. Dès lors dès qu'il reçoit un zéro sur l'une de ces 2 GA il va le considérer comme une extinction et donc la led va s'éteindre.
Si tu veux avoir une led allumée dès qu'une des lampes l'est aussi, il te faut :
- créer une troisième GA (ex 0/1/10)
- sur un module logique faire un OR avec les inputs 0/1/2 et 0/1/1 et mettre le résultat dans ta nouvelle GA
- lier l'état de la led du BP3 avec la nouvelle GA
Le perfectionnement de soi et l'accession à sa légende personnelle passe obligatoirement par le partage de son savoir et de son expérience avec les profanes en demande d'initiation. (R. Bach)
Répondre
#16
(06/03/2018, 10:55:25)pollux06 a écrit : Ton système fonctionne correctement .... en tous cas le système répond exactement à ta programmation !!!
Ca veut dire qu'il y a des choses qui clochent ? Comment puis-je améliorer?

(06/03/2018, 10:55:25)pollux06 a écrit : ... sur un module logique faire un OR....
Ca me parait logique Wink
Mais je n'ai pas ce module et surtout il me semble que lorsque c'était sous TX100, j'avais bien la fonction "Report" sans ce module?
Est-ce que cela fait partie des fonctions sous TX100 qui disparaissent sous ETS? Je dis ça car sur mes boutons WKT, sous TX100, à chaque impulsion j'avais Monter/Stop/Descendre... super pratique.. puis sur ETS obligé d'avoir impulsion longue Monter/Descendre et impulsion courte Stop.
Répondre
#17
(06/03/2018, 21:22:41)DK26 a écrit : Je dis ça car sur mes boutons WKT, sous TX100, à chaque impulsion j'avais Monter/Stop/Descendre... super pratique.. puis sur ETS obligé d'avoir impulsion longue Monter/Descendre et impulsion courte Stop.
Ces fonctionnalités sont configurables dans les propriétés des boutons ; je ne comprends donc pas la raison d'une différence de fonctionnement entre ETS et TX100 ?
Répondre
#18
C'est ce que je me dis aussi.

Mais les docs sont claires:
Descriptions d'application TX100 (https://www.hager.fr/files/download/0/10...A_FR.PDF):
Appuis successifs sur le bouton poussoir ➜ cycles Montée , Stop , Descente

Description d'application ETS (https://www.hager.fr/files/download/0/10...A_FR.PDF):
Un appui long permet d'émettre des commande montée ou descente sur le bus via l'objet Montée/Descente.
Un appui court permet d'émettre des commande stop sur le bus via l'objet Stop/Inclinaison

Je vais demander à M. HAGER
Répondre
#19
(07/03/2018, 12:25:13)DK26 a écrit : Je vais demander à M. HAGER

Oui car on parle souvent des limitations de TX100 par rapport à ETS mais c'est la première fois que je lis que l'inverse existe !
Répondre
#20
Un des principale problème qu'avait Hager sur du vieux matos (je ne sais pas entre quel date et quel date) c'etait au niveau des flags. Sur certain produit tous les flags ou presque activé, impossible de les désactivé (enfin ca ne fonctionnait pas comme on voulait) etc....

Tout était fait pour le TX100 mais il y avait du coup prb sous ETS.

Tu es peu être dans ce cas là.

Après de nos jour j'espere que le matos plus recent fonctionne aussi bien sur ETS que sur TX100 ^^^
KNX Partner Base / Avancé
Répondre
#21
(07/03/2018, 12:50:20)Ives a écrit :
(07/03/2018, 12:25:13)DK26 a écrit : Je vais demander à M. HAGER

Oui car on parle souvent des limitations de TX100 par rapport à ETS mais c'est la première fois que je lis que l'inverse existe !

Réponse de M. HAGER
...
Effectivement en config ETS il y a toujours un appui long pour lancer la manœuvre du volet roulant.
Une astuce consiste à utiliser deux BP.
Le 1er en mode télérupteur sur le montée/descente du VR
Le 2eme et écriture ON sur le stop.
...

Hager a le mérite d'avoir trouvé une parade mais cela oblige d'utiliser 2 boutons pour n'avoir que des appuis courts sous ETS  Confused
Le E-mode n'est pas si limité que ça Tongue
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)